.X File import

Hi vvvv

I’m trying to import textured 3D model .x file from sketchup, however when imported to vvvv’s renderer, there’s only a mesh (solid object) in green color without texture or render.

Do anyone experienced this subject? How to display it with texture?
Please help


you have to load the texture with FileTexture (EX9.Texture).

there’s only single file?, What kind of file should i input to FileTexture? since when exported file from sketchup,

please explain a little bit since i’m really new to vvvv

I’ve tried connected TextureFileName Pin to FileTexture node’s input and connected its output to renderer, it seems not really correct, right?

normally there is a pin on XFile saying texture filenames, so you have to connect it to filetexture…

filetexture takes image formats on input (jpg,png,dds)

I’ve tried but still texture doesn’t appear. it’s appear only single colour else black

these 2 attached img are
1.) didn’t connected the filetexture
2.) connected with filetexture

… no text …

didn’t connected the filetexture (ScreenShot) (55.0 kB)
connected with filetexture (ScreenShot) (51.8 kB)

you will need the texture file as well. put it somewhere besides the patch or the x-file and set path to it at the FileTexture node.

thanks you, I’ve tried, however, any files i input to FileTexture node, the outcome is just in black. Don’t know y?

Does anyone has successful sample of input real texture onto .x file?

your mesh seems to miss texture coordinates, use a VertexDeclaration (EX9.Geometry Mesh) to check that. compare it to the .x files in the vvvv folder, like softbox or the v.

Thanks for your help. I’ve checked it.
When I using softcube.x, i can input the texture no problem.
So i changed back to my file, VertecDeclaration shown the same parameter as softcube, but it still rendered in black.

one thing i notice is that at the output pin, TextureFileName and Subset in File, of xFile node, the soft cube shows 1 but my file shows 92.

Is that mean i have to input some source of colour slices, HOW?


hey m8 your screenshot looks like texture image files from your X are not on the same folder on your hdd so it finally loading nothing
Pls make an archive with X file, and texture files.
Filenames pin have to show you path to your textures check if it correct
(must look like TextureFileName: texture.jpg if it says TextureFileName: default (or just nothing) means you don’t have texture on that object)

Thanks a lot antokhio, very appreciate for your help.

It seems like i don’t have its texture file for my x though since there’s none of .jpg file been export. (I’m export from plugin of Sketchup8.0, only single file of .x has been exported)

ScreenShot is as attached file.
Right now i’m doing in other way round which i think it’s wrong!(i put the 89 color slides, since there are 89 mesh exported from original file, manually into ‘Ambient Color’ pin, in which correct one suppose to input through texture pin.) but it work for this moment.

Does it have any better way of doing this?? or How to export sketchup file or other 3D file WITH texture? which program is most suitable one?

very very appreciate for your help . thanks in advance

Screen shot of what I did which i think it’s not really correct (92.9 kB)

continued here: https://discourse.vvvv.org/