Forum

WriterNRT weirdness

I’m just trying to render off a preview avi, but when I come to piece together the stills, the depth buffer is off, but in the renderer that nrt is connected to its on. I do have another renderer with depth off and Im then composting that into the renderer with it on.
Its most odd!
Any ideas how I can render off stills from this?

Cat

Just tested by deleteing the renderer with no depth buffer and it still writes files with objects inside out! They look fine in the render window, I’m perplexed!

haha. sounds definitely funny.

what i could only think of is probably a memory shortage resulting in the dc9texture not being able to create an additional depthbuffer. does renderer tty say anything?

Havent checked the TTY but its not that complicated a patch, I thought the NRT just saved what was drawn on the screen though, which is what paticularly supprised me!
I’ll check tty and get back to you

Nah TTY says nothing at all!

strange. if tty renderer say nothing then vvvv is probably missing to print an error-message when it fails to create a depthbuffer.

still strange that it fails to create one, if you say the patch is not that complicated… can you try on another machine?

actually the writer does not write what the renderer shows, but what the dx9 texture shows (which are two different things - that should look equal though). if you open the module and connect the dx9texture to a quad you should also see missing depth buffer.

Still havent look at tty (doh) but I have tried this with an ATI card and the depth buffer renders this way so its an nvidia driver problem it seems.
Also DXtex - quad - different renderer does indeed display the same problem.

There are some new Nvidia drivers out, and they solve this issue, so it was their fault not yours!

puh…thanks for letting us now.

I´ve got the same problem…
So i downloaded the latest nvidia driver , still the same problem! arghhh .I have make some experimentation and when i disable the antialiasing from the renderer (the one i use as a texture ) the backbuffer on the final renderer finally works …
So maybe a little bug?