Writer (ex9 texture) freezes renderer

When I bang the “save” pin in writer(ex9 texture) the renderer pauses my animation. Why is this happening? Is there a way to save a PNG file while having smooth animation in the renderer?

Please take a look at my example file - bang the save pin and you will see the renderer stop for 1 second.

simple_writer_example.v4p (13.2 kB)

helo qwiks,

i am afraid i see no way how to do this without the hickup. in vvvv all rendering is done within one thread, so if writing to disk takes 1 second it will block the rest of vvvvs pipeline for that time.

Maybe it would be possible to write a plugin that writes the file in another thread? For me saving large textures takes several seconds.


ah yes… I thought there was this option, I should look more closely next time before posting.


there are different settings for fullscreen and windowed mode.

check the pins called “Backbuffer Width” and “Backbuffer Height” for setting the renders internal resolution :) Normally they are set to 0 (which means that the renderer has the exact size of the window) but you can set them to any fixed size.