Forum

Writer (DX11.Geometry OBJ) bug (InstanceNoodles)

Hallo,
Writer OBJ misses always a face ej:

Cannot confirm: just exported grid, box and torus from vvvv primitives correctly; also, correct UVs.
Post your x mesh and the patch with which you’ve built it, if there’s one, it’s likely there are errors in there.

Yes it is working on my laptop, while the issue was on the PC, both are i7 Sandy Bridge, PC with gtx1080 and laptop with gtx675mx. I ll check later again on the PC.
tx
Simone

I can confirm it does not work on my PC, this is the example patch

writer test.zip (2.7 kB)

I see you used Instance Noodles, while I used obj-writer.
So @everyoneishappy.
Anyway the definition of polygonal face for the last polygon is the same of the first polygon
Changing the very last line to
f 72/72/72 71/71/71 70/70/70
solves the issue in meshlab, but not in vvvv, which keeps missing it somehow.

@io I’m busy with work atm, so please feel free to make a pull request if you find the problem, otherwise I’ll get around to it at some point…

Hallo, I think this is more related to the Writer (Advanced) … I have redowloaded the addonpack for x86 and it works, but it still does not work for x64.

@io did you ever find the cause for this? Can you confirm it’s something with Writer(Advanced)?

Crashed using an Intel Skull Canyon NUC. Not sure which part of the writer is creating that problem. NUC uses an Intel GPU for which I updated my drivers… Can anyone using a NUC confirm this bug?

@guest does it crash with any geom? or only after a certain size?

On the NUC it crashes as the help patch loads.

In the patch I’m making it crashes as soon as I start writing a geometry, any geometry. It all works fine on my computer with an Nvidia GPU.

Hmmm, don’t have a NUC to check on. You might try to isolate if the NUC has problems with readback nodes in general, or if it is in fact something about the module. You can expect a pause during usage, maybe it’s quite long somehow on the NUC… I guess you tried updating the drivers?

Its a full on “go to Microsoft to see what the problem is” - type crash rather than a pause unfortunately…

Yeah tried updating the drivers. I think they are the issue though. It may well be related to readback. I’ll keep my eye on it.