Forum

Windows 8.x issues

another random thought: when running dx9 in debug mode (via dx9 control panel) do you get anything in the event-log regarding this problem?

Sorry but apparently not an easy thing to do.

Source

bump… no text …

oui, sore fo late on this one. difficult to smell the bugger without a device at hand. now please check the latest alpha build.

  • the build has a new fullscreen swapeffect flipEx which needs to be used on win8.1
  • this only works with /dx9ex
  • and it only works without antialiasing!

for now i only tested a simple fullscreen case. were there also problems in windowed mode?

so apparently antialiasing with dx9 and win>8 needs an extra renderpass for fullscreen, horray. and at some point we should now probably default to /dx9ex loosing Flash (EX9) and Text (EX9.Geometry) which should be manageable.

please test and report.

oki.

Maybe Meso or Satis are willing to sponsor a PC for debugging. I could ask Markus or Max if you like… Or maybe nsynk? A windows 8 evaluation copy that lasts for 90 days can be downloaded here.

  • It is possible to go to fullscreen when starting vvvv with /dx9ex

  • changing Fullscreen Swap Effect to flipEx is not necessary

  • changing Windowed Swap Effect to flipEx results in the following error and the renderer stops rendering:

    00:04:43 * : Cannot create SwapChain. Try different parameters!

  • When setting Windowed Antialiasing Quality to something different than NONE, Windowed Swap Effect is reset to discard and discard is the only option that can be selected.

  • Same goes for the respective fullscreen pins.

  • when setting Fullscreen Swap Effect to flipEx without /dx9ex The renderer crashes and TTY throws the following error which can be fixed by deleting the renderer, alt+right-click doesn’t help:

    00:02:21 * : couldn’t draw vertexbuffer. D3DERR_INVALIDCALL

  • Antialias seems to work just fine in fullscreen when leaving the the swap effect set to discard

  • Windowed Antialiasing also works

  • Fullscreen Dimensions AsDesktop doesn’t work, native / desktop resolution is 2880*1800 but AsDesktop results in 1024 * 768

  • Windowed Mode (“borderless fullscreen”) works

  • Last but not least: The high DPI scaling problem is back or maybe I didn’t test thoroughly enough the last time. It now doesn’t occur after leaving fullscreen. But after closing vvvv the “Disable display scaling on high DPI Settings” setting in vvvv.exe -> Properties -> Compatibility Tab is enabled again (only if a renderer went fullscreen on the primary display). So before starting vvvv again, the setting has to be disabled :(

For now the HIGHDPI nuisance can be avoided by startig vvvv / a patch via batch file containing the following line:

reg delete "HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers" /va /f

Sample attached.

start-vvvv.7z (286 Bytes)

it’s fine, i have a device now which i tested the flipEx thing on…
but indeed i didn’t just test with /dx9ex and swapeffect discard which i can confirm to work now.

so if we forget flipEx and just say win>8 needs /dx9ex for going fullscreen… would there be anything left with renderer problems?

(the fact that there is only discard available when AA is used is a dx9 limitation.)

Nothing I know of other than AsDesktop not working as advertised.

I thought so, only wanted to state all my observations because I assumed you had no device to test on.

concerning AsDesktop: does the AsDesktop TTY message also report 1024x786? and do you have your native resolution in the dropdown list of the renderer?

When setting AsDesktop TTY reports 1440 * 900 which is half of the native resolution. This relates to the display scaling setting (200%) - when the scaling is set to 150% TTY reports 1920 * 1200. But Actual Backbuffer Width / Actual Backbuffer Height output 1024*768 in fullscreen. The native res is in the dropdown and works.

edit:
Ok 1440900 is not supported so it defaults to 1024768. When using 150%/19201200 it “works” since 19201200 is supported. Still it should be 2880*1800.

alright, thanks. that should be easy to fix. i’ll have a look whether delphi can extract the DPI scaling percentage and correct the readings.

ok, wasn’t that complicated. please check AsDesktop again with alpha 24c175d6ae or later…

@tf latest available alpha was built January 4th.

@bjoern: until our alpha download website is updated, pls check build server directly with guest login for latest alpha builds: http://vvvv.org:8111/project.html?projectId=vvvv45_alpha&tab=projectOverview

AsDesktop now works as expected.

Unfortunately I found another one:

When dragging the renderer to a second screen it stops working in windowed mode. No exception, nothing in TTY (other than AsDesktop resolution change). When going fullscreen it starts rendering again, also when bringing it back to the primary display.
After setting Windowed Swap Effect to overlay part of the content is shown but scaled and “not moving with the renderer window”.

@bjoern: i can’t reproduce the last issue you described - tried with beta31.2 and latest alpha build (x86 and x64). moving the renderer window from one screen to the other and back works. what did i miss?

I tried with vvvv_45alpha31.5_x86 (24c175d6ae).

  • start with /dx9ex
  • open patch
    (I use the attached bat-file)
  • drag renderer to second display -> rendering stops
  • go to fullscreen on second screen || drag renderer back to primary display -> rendering starts again.

Win8Debug.7z (2.3 kB)

your patch works just fine, regardless of the used vvvv version or whether i use the dx9ex switch or not.

running on win 8.1 pro, geforce gtx 285 (driver version 331.65).
two screens, one 1920x1200 the other 1920x1080.

i hereby declare vvvv dpiAware.

please check with latest alpha and report. there may be some off pixels left but basically everything should now stay in place even if you choose other than 100% scaling via
Control Panel\All Control Panel Items\Display

EDIT: please start a new thread in the alpha forum if reporting regarding this.

now that vvvv is quite aware of windows’ dpi-setting and we set /dx9ex by default all of the issues in this thread should be addressed by the latest alpha build.

@bjoern: i tried the “renderer on second monitor” issue on another machine and also cannot reproduce it. this was on win8.1.

so please consider this thread closed and start new threads in the alpha forum for now if you still see anything bugging.