Windows 10 updates


#1

How to completely disable win 10 updates. I am doing this, but it is not quite enough

  1. making connection metered, also when using ethernet, through regedit
  2. disable windows updates using Gpedit.msc (setting it to: Notify for download and notify for install (This will not even pop up if you use custom UI))
  3. running vvvv as custom UI using gpedit.msc

I still get pop ups that want to update… how can I avoid these pop ups?


#2

That’s crazy!!
Signing out of Microsoft Account sounds stupid but at least no more unwanted updates!
Just on the start up it says “Update failed due to problem accessing your account”


#3

Don’t know if it will help but from my notes:

With regedit, go to:

HKEY_CURRENT_USER\SOFTWARE\Policies\MIcrosoft\Windows\Explorer (create if it doesn’t exist)

Add new DWORD (32-bit) and name it DisableNotificationCenter , set value of the key to 1

You also need to disable all security messages in Control Panel/Security and maintenance

Might be other places too where you have to disable notifications.


#4

https://winaero.com/blog/winaero-tweaker-0-7-0-1/ I think you can disable updates using this (I’ve not checked, found it the other day)


#5

or just disable windows update service


#6

@eps, that sounds like the way forward


#7

that doesn’t necessarily help.

try it, you’ll find the windows update service is magically enabled again after a few weeks.


#8

I was doing it like this
but still without being sing in to a microsoft account, I woke up with this other screen

I made a clean re install from the latest iso downloaded from microsoft website, but still its a pain


#9

I never sign in to a microsoft account, except on my personal devices.

I think @eps’ suggestion of killing the update service sounds promising, so I am testing that out now


#11

grab yourself a pro licence, switch to semi-annual channel. Select feature updates to be delayed by 365 days, Security updates can only be delayed by 30 days. if your pc is on the internet, consider installing security updates.


#12


#13

#14

@sunep , just as a report:
Got a high end PC at university for real time rendering and m.r. stuff which has win10 pro, that’s how we’re dealing with this issue:

Select the Start button, then select Settings > Update & security > Windows Update . Under Update settings, select Advanced options.
Turn on Pause updates. Note that, after a certain amount of time or after canceling a pause, you’ll need to install the latest updates before you can pause updates again.
**NOTE:
I recommend to schedule a manually “check-up” every 30 days, by turning OFF Pause updates, and after downloading and installing new version(migh take up to an hour), turning ON Pause updates again! otherwise auto update will take action by itself after 35~ days.


#15

Just reporting back, that I have been testing winaero, and it does stop updates, in order to even check for them, you have to untick the box. This is with win10 home, so seems to be a solution to me.