Forum

Webserver or webcontrol

hi!

i need a simple conrol of v4 through a website: a page with 6 buttons which each can pass a bang to v4 (on click). or at least the information that it is triggered. the website will be located on the same pc as the v4 patch is running on and accessed by 5 ipads in the same wifi network. i prefer a website for that because It should have a specific design and some extra text information and should run in a locked kiosk mode on the ipads. so an OSC app or something similar seems to be no solution. on the other hand I’m not a good coder and I have only little html and java script skills. so I got stucked with the http nodes. I tired it with vvvv.js which seemed quite good for what I need but the connection to vvvv is not working (for me). I tried the websocket contribution but on the v4 side it crahes v4 if I enable the node through the pin or inspector. does anyone know about this issue? it is already mentioned in the vvvv.js-forum but not answered. I was looking for other webserver examples in the forum but some of the examples were almost broken with a lot of red nodes and lost connections. I couldn’t figure out how to fix these.

would be happy about any hint or help!

thanks!

attached is a fixed version of the rather legacy but still working WebInterface demo found in \girlpower\IO\Web\ (will come fixed with versions >beta34)

an alternative is this contribution: venode

09_Web Interface.zip (51.5 kB)

thanks joreg! unfortunatley my browsers can’t connect to the localhost:81 server. the port is not in use by any other application. setting up a server page is working fine with http (network server) from girlpower folder. I can’t get the venode patch working, too. the plugins are all red (message, setmessage, store…).

hm, strange that it doesn’t work for you. what does the browser say?

also:
“setting up a server page is working fine with http (network server) from girlpower folder”
can you elaborate what exactly works for you here?

regarding venode: have you tried the 0.3 version? or as i pointed out in the comments on that contribution: "with venode0.5 you also need message v1.33

ah. yes. I took message v2.0. now took v1.33 and it’s fine! THANK YOU!