Waveplayer won't play waves

the waveplayer node doesn’t work for me. It’s somehow strange. The help patch works, but only with the example file. when i copy the help patch into another patch nothing works anymore. Output pins show Duration 0 and no routing info. Samples are 16bit 44 khz.

Any ideas?

use filestream instead, but try to search on forum first

yes, but the problem with filestream is that fading between waves is not possible. and that would be key for the project i’m working on. hm…

did you try using both 2 Filestreams and 2 AudioOuts for fading?

i was thinking about this. It would be not very optimal since i allready using 4 audio out for surround sound of 2 sound layers. The files are changing fast so i would need to build a complicated two channel mixer for each stereo cahnnel. waveplayer would make things incredible easy. why does it not work anymore?

…or check the Bass plugins by @vux (part of the addonpack)

read more:

cannot really confirm. can you upload a sample that does not work for you?

bass nodes are another troublesome topic for me. never got them to work with phase 26 usb external soundcard + asio4all drivers. maybe i try it again to nigth.

i attached one of the samples.

thanks for your help!

example_waveplayer.rar (569.5 kB)

waveplayer is quite picky with its fileformats. i made it more tolerant and your file works now for me. pls check latest alpha.

thanks joreg! it’s still not working for me and the alpha release doesn’t work with the rest of the project anyway…

Still curious what the problem is.
But for now i think i’ll try to solve this problem using max with osc from vvvv :)

odd, can you please try with this alpha. open the helppatch of WavePlayer and choose the file you uploaded here. just did that and works for me.

i am not too familiar with audio-file-formats. just some kind of header-format or something of your file was rejected by waveplayer. i just made waveplayer to still try to open a file if it thinks the format is not right. and in the case of your file it worked.

Hey guys so I am having the same issue except no wave files are working at all. not even the example file. joreg, how do I make waveplayer ignore the file format?

hei Jazmin,

you cannot make waveplayer ignore the fileformat, i did this in code and provided a new vvvv alpha to test. have you tried with this one?

but if you say not even the example file plays, there maybe another issue. do you get sound out with FileStream (DShow9) at all?

hey joreg i tested it with the new alpha and getting the same problem. Only the help patch runs fine. The help patch doesn’t work in another patch window and changing a file in the help patch doesn’t bother waveplayer. it continous with the example file. I also tried to put other files in the assets folder and tried diferent driver settings. nothing helps. filestream works good.
makes sense?

sadly no, since i was perfectly able to reproduce the problem with the file you provided, and fix it. so it is now difficult to understand how that fix would not work for you. you sure tried with the file you provided me and with the alpha i linked to above?

if i open that alpha’s waveplayer helppatch and select the file you provided it plays for me.

hi joreg yeah the FileStream works fine with a simple patch but the wave player just doesn’t do anything. I tested it on my friends computer and its not working for him either. It should be noted that we have the same computers because we are at the same college and have been using the laptops they provided us with. I don’t think that would effect anything but you never know…