Vvvv.tutorials.mapping.3d Problems

hello! i’m new here and in vvvv, i’ve followed some basic tutorials, but i have some questions. and sorry for my poor english.

im trying to fallow this:
i did some projection mapping before, but in 3d editors, what to try some interactive stuff now.

…and i’ve stuck everywhere, i have some red nodes, but looks like those files are on the place in the folder. is this possible?
what i’ve understood is that i have to download VVVV.Packs.Image instead of openCV.
and i’ve download different versions of the tutorial files. but none of them are works properly, always CalibrateProjector node is missing.

i’m not sure if i’m downloaded Packs.Image correctly, i’ve downloaded dx11, and i have packs folder and i’ve installed Packs.Image inside packs/dx11 folder.

this was solved.

can someone help?

you need to put the /Image.Pack folder besides /dx11 not into it.

see also: nodes and paths

Yeah, I’ve tried to install image pack in a way discrabed in this article, and I’m still had red nodes. But maybe i’m misunderstood something, I will reinstall and double check everything. Is there any information what is outdated in this tutorial, what possible to replace?

i’m reinstalled everything. now here is how my folders looks like, and what happening when i’m starting ProjectorN_b31.2 (DX11) tutorial files for example.

can you see these screenshots? i can’t =)

@azercay you forgot to press the “Insert” button next to the images you uploaded

uk, i had a look at this beast and the problem is that @elliotwoods left it in a bit of a, lets say “hybrid” state.

the tutorial relies on his (now legacy) vvvv.nodes.table which i included in this download and fixed all links to broken nodes (which i found). not sure if i found all of them.

also as you’ve noted the mentioned openCV pack is now legacy and replaced by vvvv.packs.image which is only available for x86 builds.

so anyway, if you get latest vvvv45beta34.2 x86 + addonpack x86 + that imagepack then you should be able to open the “fixed” patches i upload here. at least you should not see any more red nodes. otherwise i am afraid i cannot guarantee that the rest will work. please report.

VVVV.Tutorials.Mapping.3D-for-b34.2.zip (1.4 MB)

thank you very much, @joreg!

looks like you’r fixed a lot of things there. but something there stil won’t work.

if you have the image-pack in the right place, like:
it should be found. if not please hover the red node with the mouse to see the path of where vvvv is trying to find the node.

I have a feeling calibrate camera is missing from the latest pack, last time I tried to use it I had to delve into old versions…

for me CalibrateCamera (CV.Transform) + helppatch is there when i am using b34.2 x86 with the latest imagepack.