VVVV super slow FPS!+++

I’ve got an i7 core, running brand new XP-32bit install, installed all dotnet2.0, directX, SlimDX, run vvvv 23, ran as admin,

create a renderer,
FPS around hovers around 23,

debug mode shows renderer flickering between 400-4000+!!!

TTY renderer shows nothing usual.

Other test patches show same issue.

Increase timing precision set to 1 on mainloop.

Swapped graphics cards.

older versions off vvvv show the same.

Anyone any ideas?

ok more info and sorted.

It turns out renderers kinda do that anyway, something I had never noticed before. On an i7 core this ends up a higher number and I’m guessing because it is running faster.

I panicked a bit because my drawing app that uses the flash renderer into a GDI texture was running really slowly on the new i7 system. On a quad core system the same patch runs at around 180fps, on the i7 it was 35fps. I put this down to the high numbers coming out the renderer in debug mode. Changing the texture format on the GDI texture from no specific to R5G5B5 sorted this out, but on other systems it seems makes no difference to the fps. odd. I double checked this.

On the i7 the final rendered format is set to R5G5B5 and the GDI texture set to no specific > system runs 35fps.

On the quadCore the final rendered format is set to R5G5B5 and the GDI texture set to no specific OR R5G5B5 > system runs 180fps.

On the i7 the final rendered format is set to R5G5B5 and the GDI texture set to R5G5B5 > system runs 240fps.

Same graphics cards.


my i7 core is still running slower than my quad. The quad seems happy to run the GDI texture at any format. The i7 really struggles with anything better that r5g5b5. Same graphics cards, same setting in nVidia control panel. Any ideas? Anything I can try.

anybody using an i7 core with vvvv?

@devs. how easy would it be to change the GDI texture node so it was multi-threaded? Not only would I get better performance out of my i7 with flash, but we’d be able to share textures across graphics heads.

helo xd,

sorry for late. can you provide a patch that demonstrates your problem? i have an i7 at hands. opening a renderer with perfmeter gives me full 60fps and setting renderers presentation interval to immediate i can toggle between 60 and 120fps with mainloops improved timing precision (just for a test…)

also, why are you not using the new flash plugin instead of the gdi-renderer?

hey joreg. only just spotted you’re reply to this. I wasn’t subscribed! So yeah I havn’t got much further towards solveing or develing deeper into this issue. I’ll let you know more when I do get back into it one day. Sticking to quadcores for the time being.

I don’t use the new flash plugin because I get better performance from the gdi renderer oddly enough. If you create the new flash(ex9) node and look at the performance in task manager you’ll notice major usage. Posted about it a while ago here http://legacy.vvvv.org/tiki-view_forum_thread.php?comments_parentId=30406&topics_threshold=0&topics_offset=83&topics_sort_mode=lastPost_desc&topics_find=&forumId=4