Forum

Vvvv SDK init not working

justing trying to setup the vvvv-sdk
things went terribly wrong with an old fork therefore i just killed the fork and started off fresh with a fork from today’s version

did all exactly like stated here: vvvv sdk

until init problema:


its asking me for x86 or x64, i entered x86 then this:


mmm, whats wrong ?

i checked if i can pull from upstream, just to make sure all is most recent

seems happy…

my conclusion, the init script is funky…

please help

had the same issue yesterday, just download the vvvv.exe manually and place it into the directory.

building with the nuget was a little bit freaky as well (sometimes i have to clean solution and rebuild to get rid of errors), if you find out more i guess elias will be happy to hear.

regarding the init script:
the init script does nothing more than calling the fetch-binaries script. and yes the fetch-binaries script was broken due to the build server change. i fixed it two days ago, but in order for it to work it requires a windows powershell 3.0 installation on a windows 7 system. windows 8 includes powershell 3.0 already. another option would be to rewrite the script using either methods from powershell 1.0 only or as a plain bash script. will have to look into it…
alternatively you can use the following links to download the latest binaries:
x86: http://vvvv.org:8111/viewType.html?buildTypeId=vvvv45_alpha_x86&branch_vvvv45_alpha=<default>&tab=buildTypeStatusDiv
x64: http://vvvv.org:8111/viewType.html?buildTypeId=vvvv45_alpha_x64&branch_vvvv45_alpha=<default>&tab=buildTypeStatusDiv
and yes, i’ll need to add these instructions to vvvv-sdk wiki page.

regarding build issues:
we’re building the vvvv45/addonpack solutions many times a day here and never experienced any issues :/
can you be a little more specific what you’re doing exactly when these build issues come up?

probably easier and safer to drop the binaries manually. its not really convenient to install just another bit of software just to get the bins.

or …probably stupid question… can the bins be part of the vvvv-sdk ? would make things easier…

hi elias! as of git you seem to blame ;)

sorry to report another failure… my current checkout of the sdk was broken by the latest develop tip! neither was i able to build anything, nor to run the init script without failure.
i just made a fresh clone of the SDK, to avoid any historical issues with my fork, but no luck sam error… o_O

i installed the powershell 3.0 via the recommended windows update (as of google…), so the powershell script runs.

but when i run the ./init (as explained in the documentation) i get this: https://vvvv.org/sites/default/files/imagecache/large/images/Bildschirmfoto%202013-12-08%20um%2018.02.25.PNG

after i made the following change to scripts/fetchBinaries.ps1

-$packagesPath = Join-Path $scriptPath "..\packages"
-$vvvvRootPath = Join-Path $scriptPath "..\vvvv45"
-$solutionPath = Join-Path $scriptPath "..\vvvv45\src"
+$packagesPath = Join-Path $scriptPath "..\..\packages"

M
+$vvvvRootPath = Join-Path $scriptPath “…\vvvv45”^M
+$solutionPath = Join-Path $scriptPath “…\vvvv45\src”^M
^

the fetch works now. i wonder how you fetched the binaries!?? i make a PR shortly.

sharp develop and VS 2012 build both solutions just fine (VS 2012 had some nuget package recovery error…!?).

but on the suicidal risky attempt to build it in VS 2013, the following errors pop up (@u7angel: actually the same we saw, when we build from your updated fork, so nothing wrong with your fork… was VS 2013 too…):

Fehler	1	Der Befehl ""C:\Program Files\Microsoft SDKs\Windows\v8.1A\bin\NetFX 4.0 Tools\ildasm.exe" /nobar /linenum /output:"C:\vvvv-sdk\common\src\core\UtilsIL\obj\x86\Debug\VVVV.UtilsIL.il" "C:\vvvv-sdk\common\src\core\UtilsIL\obj\x86\Debug\VVVV.UtilsIL.dll"" wurde mit dem Code 3 beendet.	C:\vvvv-sdk\common\src\core\UtilsIL\UtilsIL.csproj	63	5	UtilsIL
Fehler	2	Die Metadatendatei 'C:\vvvv-sdk\common\src\core\UtilsIL\bin\x86\Debug\VVVV.UtilsIL.dll' konnte nicht gefunden werden.	C:\vvvv-sdk\vvvv45\src\core\Utils3rdParty\CSC	Utils3rdParty
Fehler	8	Die Metadatendatei 'C:\vvvv-sdk\vvvv45\lib\core\VVVV.Utils3rdParty.dll' konnte nicht gefunden werden.	C:\vvvv-sdk\vvvv45\src\core\Hosting\CSC	Hosting
Fehler	9	Die Metadatendatei 'C:\vvvv-sdk\common\src\core\UtilsIL\bin\x86\Debug\VVVV.UtilsIL.dll' konnte nicht gefunden werden.	C:\vvvv-sdk\vvvv45\src\core\Hosting\CSC	Hosting
Fehler	10	Die Metadatendatei 'C:\vvvv-sdk\vvvv45\lib\core\VVVV.Utils3rdParty.dll' konnte nicht gefunden werden.	C:\vvvv-sdk\vvvv45\src\nodes\plugins\Mesh\ColladaLoader\CSC	PluginColladaLoader
Fehler	11	Die Metadatendatei 'C:\vvvv-sdk\vvvv45\lib\core\VVVV.Hosting.dll' konnte nicht gefunden werden.	C:\vvvv-sdk\vvvv45\src\nodes\plugins\CSC	NativePlugins
Fehler	12	Die Metadatendatei 'C:\vvvv-sdk\vvvv45\lib\core\VVVV.Utils3rdParty.dll' konnte nicht gefunden werden.	C:\vvvv-sdk\vvvv45\src\nodes\plugins\CSC	NativePlugins
Fehler	14	Die Metadatendatei 'C:\vvvv-sdk\vvvv45\lib\core\VVVV.Hosting.dll' konnte nicht gefunden werden.	C:\vvvv-sdk\vvvv45\src\nodes\editors\CodeEditor\CSC	CodeEditor

you can imagine the waterfall of errors for the addonpack…

but VS 2013 is optinal imho. still, any idea? seems to conflict with the windows SDK 8.1a!?

and another question: why do i have to put in my platform code after every bloody checkout/branch switch?? it was automatic in the past. secondly, when i have my own branch (virmata-develop, fetch-binaries-fix, etc) the binary fetch fails, telling me no suitable binaries were found and might want to try to increase the maxCount (but not how…). any chance this can be resolved to work as easily as before? this is broken!

what happened to the script? it worked so nice before…

gr!j;

regarding the init script see my blog post.

regarding build issue on vs2013: i do not have vs2013 available here, but i installed the win sdk 8.1 and saw that indeed the subpath to ildasm.exe changed. i’ve updated the UtilsIL.csproj accordingly. see https://github.com/vvvv/vvvv-sdk/commit/e9afa8a5f8ba9873607b870ec1752684d49b3715 - does it work for you now?

hey elias, i’ll try asap!

sorry for double post: works for me on VS2013

hey guys,

i still have trouble getting the SDK running.
Partly i think its caused of firewall im behind, but when i finally got the binaries i got lot of errors when building. Maybe something with Nuget not working?
Also do i have to use VS2012 or can i continue with VS2010? Express versions enough?

Would be nice to get this working again.
Maybe someone could explain how to do it manually in case someone sits behind firewall.

you can continue to use vs2010 - just make sure you have the latest nuget package manager extension installed. if so, you should be able to right click on the solution, select “manage nuget packages” and on top of the package dialog you should see a message like “There’re missing packages, click to install …” which should take a little while. after that your best bet is to close the solution and reopen it, so all projects and their referenced packages get loaded properly. then make sure to set the solution configuration to x86/debug and build the solution.

Thanks! I was missing the nuget manager. So Visual Studio Express versions cant be used, as nuget manager requires pro versions.
http://docs.nuget.org/docs/start-here/installing-nuget

Can you tell me which port is used to fetch the binaries via the powershell script?
Getting lots of errors “unable to connect”. Sucks sitting behind a Firewall i cant control :(

I think it would be a good idea to add this information to the sdk-page. And maybe add a line about what to do after “pulling the upstream”, for us Github newbs :) How to update your own fork. (Rebase / Merge -> Push etc.)

if you don’t have a vs-license consider using SharpDevelop instead (which i actually prefer for it feeling more leightweight).

and please refine your question regarding “what to do after pull upstream”. basically then you have all the latest sources, build and can get to work…

hi again,

any chance for a small tutorial into getting vvvv SDK compiling in SharpDevelop?
I need to switch as newest alphas switched to .NET4.5 and VS 2010 is not supporting that.

When i open latest sources in sharpdevelop i get a ton of errors when building. Starting with nuget:

Der Befehl ""D:\github\vvvv-sdk\vvvv45\addonpack\src\.nuget\NuGet.exe" install "D:\github\vvvv-sdk\common\src\core\Core\packages.config" -source ""  -NonInteractive -RequireConsent -solutionDir "D:\github\vvvv-sdk\vvvv45\addonpack\src\ "" wurde mit dem Code 1 beendet. (MSB3073) - D:\github\vvvv-sdk\vvvv45\addonpack\src\.nuget\NuGet.targets:92,9
Der Befehl ""D:\github\vvvv-sdk\vvvv45\addonpack\src\.nuget\NuGet.exe" install "D:\github\vvvv-sdk\vvvv45\src\core\Utils3rdParty\packages.config" -source ""  -NonInteractive -RequireConsent -solutionDir "D:\github\vvvv-sdk\vvvv45\addonpack\src\ "" wurde mit dem Code 1 beendet. (MSB3073) - D:\github\vvvv-sdk\vvvv45\addonpack\src\.nuget\NuGet.targets:92,9
Unable to find version '1.0.1' of package 'VVVV.SlimDX'. - D:\github\vvvv-sdk\vvvv45\addonpack\src\.nuget\NuGet.targets:92,9
Unable to find version '2.5.0' of package 'System.ComponentModel.Composition.Codeplex'. - D:\github\vvvv-sdk\vvvv45\addonpack\src\.nuget\NuGet.targets:92,9
Der Typ- oder Namespacename 'Composition' ist im Namespace 'System.ComponentModel' nicht vorhanden. (Fehlt ein Assemblyverweis?) (CS0234) - D:\github\vvvv-sdk\vvvv45\addonpack\src\nodes\plugins\Color\RGBVector\RGBVectorNode.cs:3,29

so i guess the error lies within nuget not updating the packages. How can i resolve this?

some further digging shows me some warnings that it cannot connect to the remote server.

Is nuget pulling sources from http://vvvv.org:8111 aswell?
Could this be a firewall issue again?