Vvvv sdk build errors

contributing to vvvv seems still pretty hard

i followed the sdk instructions
i have sharp develop 4.1 most recent
i have .net 4.0 installed

  • sdk sucessfully cloned
  • did the init script sucessfully
  • opened addonpack.sln…

x - already with the first error message: Assimp/Lib stuff not found

  • checked target framework 4.0 client ?
  • check target cpu x86

now tried to compile and i get this, see attached list of errors

compileErrors.zip (2.0 kB)

deinstalled all .net4.0 stuff
reinstalled .net4.0
installed windows sdk
set environment variable for .net4.0
opened addonpack.sln

and get this…depressing

would be nice to have a working step by step instruction to get the vvvv sdk working

moreErrors.zip (1.4 kB)

another pc, same game. windows sdk just wont install for whatever reason. need to deinstall all the .net stuff and then try again.

edit: been a mission, i deinstalled everything related to .net and c++ etc. as well as github for windows.


  • installed github for windows which comes with .net4
  • cloned
  • init
  • installed win sdk which deinstalled .net again and installed it with additional stuff
  • sharpdevelop now seems to be happy and finds everything except slimdx dependencies which aren’t of course in some folder called AnyCPU

the last bit i’m stuck, sharpdevelop only lets me choose AnyCPU expect for targetCPU settings which can be set to x86.

world of pain

C:\Users\flame\Documents\GitHub\vvvv-sdk\vvvv45\addonpack\src\nodes\plugins\Texture\HTMLTexture\CefService.cs(2,7) : Error CS0246: The type or namespace name ‘CefGlue’ could not be found (are you missing a using directive or an assembly reference?)
C:\Users\flame\Documents\GitHub\vvvv-sdk\vvvv45\addonpack\src\nodes\plugins\Texture\HTMLTexture\CefXmlReader.cs(4,7) : Error CS0246: The type or namespace name ‘CefGlue’ could not be found (are you missing a using directive or an assembly reference?)
C:\Users\flame\Documents\GitHub\vvvv-sdk\vvvv45\addonpack\src\nodes\plugins\Texture\HTMLTexture\SchemeHandler.cs(3,7) : Error CS0246: The type or namespace name ‘CefGlue’ could not be found (are you missing a using directive or an assembly reference?)
C:\Users\flame\Documents\GitHub\vvvv-sdk\vvvv45\addonpack\src\nodes\plugins\Texture\HTMLTexture\SchemeHandler.cs(8,43) : Error CS0246: The type or namespace name ‘CefSchemeHandler’ could not be found (are you missing a using directive or an assembly reference?

just installed sharp develop 4.2 on my home machine, followed the sdk instructions, set the active build configuration to x86 (in SD this is done via Build -> Set platform -> x86) and despite lots of warnings it built just fine. i do have the windows sdk 7.1 installed though. that’s why the assimp nodes compile. if you don’t want to install the win sdk, remove the assimp projects (Solution explorer: nodes -> Mesh -> VVVV.Assimp.*) from the solution. true, we could upload a second solution where the c++ nodes are excluded but mainaining different solution files wasn’t our top priority.

do not set the active build platform to AnyCPU. when i set up the solution to handle both platforms (x86 and x64) i tried to get rid of the AnyCPU platform, but for some reason the IDEs move it back in after some time. so i left it there and added a comment to our build instructions.

i feel truly sorry for what you experienced. we really try to get the build process simple … :/

Yeah, probably better talking via irc. Getting into the sdk was definetely easier in the early days. For a casual contributor it seems pretty hard right now and the 64bit stuff isnt going to make it better.

The instructions need a review, windows sdk installation failed on two machines and took lots of work to get it running.

The plan actually was: make some little changes to bullet therefore the 32bit version is needed.
More on irc or tonight in berlin :)

its working now.


  1. yes you need the win sdk. if it fails to install (in my case on 3 machines) get rid of all .net4 stuff and try again. thanks to microsoft

  2. if you use sharpdevelop, you need to set the solution like in the image. per default its set to 64bit. question to devs: why , when lots of stuff doesnt work with 64bit yet.

i’m wondering if the vvvv sdk page could be improved, a bit more step by step like this one


right now, the installation manual is mixed with all sorts of explainations, some things are steps, some important things are in boxes, some very important informations are in continuous text. others are optional. its hard to read and to filter, whats important for me.

wow, finally!
so your platform was set to x64 and you got above mentioned compile errors? i missed to try that combination. SD and x64. seems as if SD ignores the solution configuration. will need to check that. basically the solution works with x64, otherwise there wouldn’t be a x64 addonpack on our alpha download page…

and yes, a short 5 minute step by step explanation in the beginning of the text wouldn’t hurt i guess.

oh and setting the solution to x86 by default isn’t possible. tried for at least an hour before i uploaded it, but IDEs pick one platform when they open up the solution for the first time and save which platform the user chose in some other file, which is about 12mb for visual studio for example. so no way to check it in.