Forum

VVVV & Kinect

Hi. i cant understand how i can connect this device with vvvv? Can you give me some tutorials? thank you.

kinect

helo judi,

you need to start reading here: kinect

so first get the drivers of either OpenNI or Microsoft version installed, then when connected check out the helppatches of the nodes in the category Kinect.

After installing Microsoft SDK, what i should do next?
OS: Win 7 Pro x64

create a Kinect (Devices Microsoft), select it and press F1 to open its helppatch.

Thank you for you patience, but i have a questions again. Now i load a patch from addons from this site (which includive a patch work with kinect). But i have a red nodes now:
Kinect (Devices Microsoft) P VVVV.Nodes.MSKinect.dll [id 0](id 0)
I think need copy this dll, but i dont know where

you need to be more precise.

which patch do you mean exactly?

basically you should have gotten the addons from the downloads and with those you have all .dlls already at the right place and you should be able to create a Kinect (Devices Microsoft) by doubleclicking in any patch and creating that node. if that node does not show up in the nodebrowser you didn’t get the addons or didn’t unzip them correctly. once you have that node press F1 on it to open its helppatch.

I think what i all make correct (put addons to vvvv folder)
i try to load “Kinect (Devices Microsoft) help.v4p” but i dont see any effects. Screenshot of my vvvv:
http://img72.imageshack.us/img72/6045/screenshotvvvv.png

ok, looks good (basically) now this is where mr. vux comes in, as he is the author of those plugins. it could be interesting to open a Renderer (TTY) before opening the helpfile to see if there are any errors thrown.

Ok, will be wait what mr. vux say.

you have SDK Beta2 driver aren’t you?
http://www.microsoft.com/download/en/details.aspx?id=27876

judicator read the kinect thread fully… its a “known” issues the red nodes if you have the wrong drivers, be sure to install the 32b vercions … even if you have 64b os

Hello Judicator,

I suspect that you probably extracted addon folder in wrong place, regarding driver KinectSDK-v1.0-beta2-x64.msi from the link @antokhio has shared works well. There are the only two steps which must work. From there you may select kinect node and explore its help patch. Please try and let us know. Best!

Hi,

I have exactly the same problem. I’m trying to use a Kinect Xbox 360 on my machine with no luck at all…

Drivers are from the link above : microsoft sdk beta2 64bits. (but someone said that we should use 32bits driver even on 64bits system ???)

I’m using vvvv 27.2, extracted with 7zip, same for the addon pack.

Then I tried with the openNI driver, and same problem, red nodes, no way to use it.

When I try to use the Sample Skeletal Viewer it says : MSVCR100.dll is missing…

Any idea gentlemen ?

Thank you

openni only works with me 32 bits.

since vvvv is a 32bit application even on 64bit systems it always still needs 32bit dlls.

hi,

I’m having a slight variation on this issue. I can open a new vanilla vvvv and create an MSKinect patch. However, whenever I saved that patch, quit and reopened it, I always get the red Kinect node. And if I want to create that node again, all of the Kinect node are not there. Could it be I misplaced the addons folder? because I put it right next to girlpower as per the instruction and this problem didn’t happen with the other nodes in the addons.

cheers.

hmm, apparently, I had to open vvvv.exe first and then reopen the saved patch. or, put the required dlls in the root vvvv folder. What’s wrong here? Shouldn’t I be able to click the patch directly and open it without any trouble? Or again, is this a case of not having the addons properly placed?

Hi, ok it works if I installed the complete kinect sdk (220Mo…).

The kinect pages says that :

Microsoft
Available natively in vvvv from beta27.1 thanks to vux, the required drivers can be found here:
http://download.microsoft.com/download/F/9/9/F99791F2-D5BE-478A-B77A-830AD14950C3/KinectSDK-v1.0-beta2-x64.msi
For now it works only on 64bit systems.
A version for the final SDK is in the works by vux and will come soon.

So the link is to a 64 bits drivers and it says also “only on 64bit system”.

Maybe a mistake ?

no! it just need to be updated! You can do it or ill do it later on