Forum

VVVV freezing on startup!

Using vvvv 45beta28 on Alienware M14x r2,win7 for a while the last patch it crashed on was when i was using the audio analysis node after which it kept freezing on startup, so i tried vvvv 45beta29.2 x86 and it still kept freezing in both cases, startup logs show no errors but seem to get stuck after scanning for Externals

21:15:55.830 everything you know is wrong
21:15:55.841 creating SplashScreen
21:15:55.849 Adding lib\thirdparty to PATH.
21:15:55.849 creating GClock
21:15:55.868 creating GMainloop
21:15:55.868 creating GLog
21:15:55.869 creating GApplication
21:15:55.869 creating GGlobals
21:15:55.869 creating GNodeFactory
21:15:55.869 creating Gex9Base
21:15:55.888 Direct3D9 initialized.
21:15:55.918 ExceptionDialog is disabled. Start vvvv with /showexceptions to enable it.
21:15:55.934 enumeratig Game Devices…
21:15:55.973 found Game Devices:
21:15:55.973 enumerating Midi Input Ports…
21:15:55.973 found Midi Input Ports:
21:15:55.973 enumerating Midi Output Ports…
21:15:55.974 found Midi Output Ports: “Microsoft GS Wavetable Synth”
21:15:55.975 enumeratig TAPI Devices…
21:15:55.975 found TAPI devices:
21:15:55.977 enumeratig Audio Renderer Devices…
21:15:56.622 found Audio Renderer Devices: “Speakers (Sound Blaster Recon3D”,“Default DirectSound Device”,“Default WaveOut Device”,“DirectSound: Speakers (Sound Blaster Recon3Di)”
21:15:56.623 enumeratig Midi Renderer Devices…
21:15:56.624 found Midi Renderer Devices: “Default MidiOut Device”,“Microsoft GS Wavetable Synth”
21:15:56.624 enumeratig External Renderer Devices…
21:15:56.625 found External Renderer Devices:
21:15:56.627 enumeratig Audio Input Devices…
21:15:56.630 found Audio Input Devices: “Microphone Array (Sound Blaster”,“What U Hear (Sound Blaster Reco”
21:15:56.631 enumeratig Video Input Devices…
21:15:56.640 found Video Input Devices: “Integrated Webcam”
21:15:56.658 creating MainForm
21:15:56.690 creating AddonHost
21:15:57.222 creating NodeBrowser, WindowSwitcher, Kommunikator
21:15:57.226 creating HIDDeviceController
21:15:57.249 scanning for Externals

So then i tried vvvv 45beta29.2 x64 and that seems to work, but still unable to get x86 up and running any idea what the issue might be guys?

hei sun,

please try renaming your
lib\nodes\freeframes
directory to
lib\nodes_freeframes

which effectively omits scanning freeframe externals. please report if that helps.

i had the same issue last several days and renaming the freeframes directory worked for me.

So I guess this is and https://discourse.vvvv.org/might explain why vvvv 28 & 29 wouldn’t get past “scanning for externals” after I installed Pure Data extended package at Node… Might be a good idea to have more fine grained startup logging to be able to pinpoint stuff like this?

yea well i have my windows not starting anymore after i left my computer for few hours running in to some kind of silent error in 11… you type pasword press go and its welcome msg for hours then if you wait till it loggins you have explorer crashes like all the time, not sure what to thos tryed all the rescue options still seems the same…

@beyon: confirmed. the evil pd-installer is causing a dll-hell there. worked around with latest alpha, or uninstall pd and use the .zip version instead of the installer.

@sunjoy88, youngjae: this possibly also sorts the issue for others that had to rename /freeframes.

HI THERE
vvvv.exe.config is a file that exist next to the vvvv.exe file in root dir.

this file have a config node .

just set true to false to solve freeze problem . in other words when this property set to true vvvv first try to connect and load from remote and this consume time.

thanks.

That’s not true. LoadFromRemoteSources does not load any files from the web. It simply gives permission to load assemblies downloaded from the web. I’d suggest to leave that setting be.