Forum

Vvvv fails to start. Grey box. No 3dsMax. Win 7

Hi all,

Win 7 machine… install went fine.

vvvv won’t start… I get a grey box with version info… nothing more.

I’ve run crack in admin mode. 4 greens.

I’ve run vvvv.exe in admin mode. No 3dsMax. Ever.

Interestingly, for a time right after I rebooted… it did seem to want to run. I got an interface and display (girlpower)… but the windows had no close buttons, nor any menu bar… but the program was running… sort of.

For some reason, we’re back to the small grey square.

admin mode, autorized by windows firewall ?

if yes, check and try to update .NET

@Ryder: might be https://discourse.vvvv.org/t/8172

hei Ryder, pls try running vvvv.exe with
/logstartup
and post the resulting .log file (which is placed next to the .exe) here.

In a similar situation simply there wasn t a proper graphic adapter to run vvvv (older Intel gfx for example)
Simone

also in your screenshot i see a strange file called:
vvvv.exe.config.old.txt
thats no good. did you rename that? if so, why? it should only be called:
vvvv.exe.config

Ehh… that is just vvvv, a grey empty virgin patch.
Just double click in it to make a node, use middle mouse button to see the menu…

Solved, I think.

My reboot fixed everything… but not seeing any GUI, like close boxes etc. (standard windows GUI), I felt that there were still problems.

I renamed the config file in an attempt to get the program to write a new default config file (which programs often do), but obviously that failed.

Returning the config file to it’s proper name, and then finding the GUI “hidden” in the middle mouse button did the trick.

Thanks all!

Hi guys!

I have the same problem like Ryder had (under win7 the vvvv doesn’t start after grey patch) but i don’t find any hidden GUI window.
I have tried everything others adviced above (firewall, intel driver update, .NET update)
Could you tell me what should I do to fix this problem?
Here is the .log file, I hope it will help:

17:42:32.583 everything you know is wrong
17:42:32.645 creating SplashScreen
17:42:32.739 Adding lib\thirdparty to PATH.
17:42:32.739 creating GClock
17:42:32.770 creating GMainloop
17:42:32.770 creating GLog
17:42:32.770 creating GApplication
17:42:32.770 creating GGlobals
17:42:32.801 creating GNodeFactory
17:42:32.801 creating Gex9Base
17:42:32.863 Direct3D initialized.
17:42:32.973 ExceptionDialog is disabled. Start vvvv with /showexceptions to enable it.
17:42:33.066 enumeratig Game Devices…
17:42:33.097 found Game Devices:
17:42:33.097 enumerating Midi Input Ports…
17:42:33.097 found Midi Input Ports:
17:42:33.097 enumerating Midi Output Ports…
17:42:33.097 found Midi Output Ports: “Microsoft GS Wavetable Synth”
17:42:33.097 enumeratig TAPI Devices…
17:42:33.097 found TAPI devices:
17:42:33.113 enumeratig Audio Renderer Devices…
17:42:33.133 found Audio Renderer Devices: “Speakers (Realtek High Definiti”,“Default DirectSound Device”,“Default WaveOut Device”,“DirectSound: Speakers (Realtek High Definition Audio)”
17:42:33.133 enumeratig Midi Renderer Devices…
17:42:33.135 found Midi Renderer Devices: “Default MidiOut Device”,“Microsoft GS Wavetable Synth”
17:42:33.136 enumeratig External Renderer Devices…
17:42:33.136 found External Renderer Devices:
17:42:33.140 enumeratig Audio Input Devices…
17:42:33.143 found Audio Input Devices: “Microphone (Realtek High Defini”
17:42:33.145 enumeratig Video Input Devices…
17:42:33.158 found Video Input Devices: “Integrated Webcam”
17:42:33.191 creating MainForm
17:42:33.245 creating AddonHost
17:42:34.065 vvvv caused error during startup: GetExportedValue cannot be called before prerequisite import ‘VVVV.Hosting.Factories.StartableRegistry…ctor (Parameter=“parentContainer”, ContractName=“System.ComponentModel.Composition.Hosting.CompositionContainer”)’ has been set.

Thank you for your help!

monolit: can you please try redownloading vvvv and re-unzipping it to a nice location on your disk. but not using the windows-builtin unzipper, but rather eg. 7-zip. then try again. and report back here.

Thanks a lot joreg! It’s working! :)
Solved.