Forum

Vvvv fails to start after splash screen

IT WORKS!!! Thank you Elias! It wasn’t exactly what you suggested, but you gave me the right hint: I don’t have the addonpack installed (yet) and I didn’t rename the folder freeframe to freeframe_disabled, because there simply was no such folder. However there was one called freeframes (plural), which I renamed to freeframe, and now it works. Seems like that little s caused all the trouble. Though that makes me wonder how it can work for some users and for others it doesn’t (?)

Anyway, I can finally start exploring vvvv. Thanks a lot!

argh, i had a typo, the folders are called freeframes.
what you did is exactly what i proposed, you renamed the folder to something different than vvvv expects it to be and therefor doesn’t load the *.dll files in there. you won’t have any freeframe nodes. you can check by typing “f” and a space in the node browser.

the dlls in the freeframes directory have certain runtime dependencies. my guess for all your troubles is that you have a program installed on your machines which delivers the same dependencies and added them to your PATH environment variable. the newest alpha build you can download will now prepend (instead of append) the search directories vvvv needs to the PATH environment variable of the vvvv process. it won’t touch your PATH environment variable at all, it will only modifiy its private copy of it.
that way windows should pick up the right dependencies.

so do us the favor and try with the latest x86 alpha build and see if it works.

Ok, cheered too soon.
I downloaded the new alpha build (28.5). crack.exe told me to install Visual C++ Runtime 2008 & 2010. Both had actually already been installed. Reinstalled them, 2010 is ok now though it still tells me to install C++ Runtime 2008. Seems to work anyway.
Is a new beta or even stable coming anytime soon?
Btw: Reinstallations didn’t change behaviour of 28.1 beta.

sternmull…strange about the crack reporting missing stuff even though you installed it, but the more interesting question would be:

with latest alpha can you start vvvv.exe without having to rename the \freeframes directory before?

I didn’t rename anything in the alpha, but there is no freeframes directory in the build that i downloaded.

there’re two vvvv alpha builds:

  • 32bit - vvvv_45alpha28.5_x86.zip
  • 64bit - vvvv_45alpha28.5_x64.zip
    the 32bit build contains a lib\nodes\freeframes directory.
    the 64bit build doesn’t.

we’re interested in the 32bit build. if you download that one, does it startup without the need to rename the freeframes directory?

tried the 32bit alpha now: crashes just like the beta. crack.exe gives me all greens though.

i downloaded the x64 version in the first place because i’m on a 64bit machine. don’t know if that might have anything to do with the crashes?

@dannielmach: do you remember what font that was? maybe there are things that happen to me too ;)

it just happened that left the version 28.1 beta … I usually format the cpu when comes a new version … after all updates, upgrades made ​​ran the crack … beauty who not only ran the vvvv for the first time … installed a pack with 10 dingbats … vvvv.exe froze when I ran the … installed and uninstalled anything … then installed on another notbook with system fonts only worked … uninstalled font pack the other cpu work on time … most do not know your case … downloaded dafont.com

I uninstalled all dingbats fonts I had - didn’t solve it. Though I have hundreds of fonts from Adobe and others and I won’t go through all of them. Guess I’ll give up on vvvv now, as in the meantime I started using PD and Processing, which both work fine without any problems.

for those who also don’t get vvvv to work: try PD for professional audio programming and Processing for multimedia stuff!

To all those who tried to help: Thanks for your patience.

@sternmull in case you’re still reading:
thanks for your patience but still your reports are a bit confusing.

we’d really like to get this sorted, but would need more specific informations from your tests.

so we understand that you tried beta28.1 and it freezes. ok.
it seems that when you renamed the \freeframes directory of beta28.1 it was able to start. can you confirm this?

then you said you downloaded the latest 64bit alpha where crack was reporting wrongly missing VC++2008 runtimes but it still worked for you. can you confirm this?
if that worked, then why give up? thats most likely what you want.

but still:
then you said you downloaded the latest 32bit alpha and it crashed again!? this we cannot believe. please do us a favour get the latest 32bit alpha again, try and report your finding on this.

thanks in advance…

I have the similar (freeze after splash screen) problem…
here is my log

[00:06:31.531](00:06:31.531) everything you know is wrong
[00:06:31.547](00:06:31.547) Adding lib\thirdparty\x86 to PATH.
[00:06:31.594](00:06:31.594) creating SplashScreen
[00:06:31.594](00:06:31.594) creating GClock
[00:06:31.609](00:06:31.609) creating GMainloop
[00:06:31.609](00:06:31.609) creating GLog
[00:06:31.609](00:06:31.609) creating GApplication
[00:06:31.609](00:06:31.609) creating GGlobals
[00:06:31.625](00:06:31.625) creating GNodeFactory
[00:06:31.625](00:06:31.625) creating Gex9Base
[00:06:32.265](00:06:32.265) Direct3D9 initialized.
[00:06:32.296](00:06:32.296) ExceptionDialog is disabled. Start vvvv with /showexceptions to enable it.
[00:06:32.327](00:06:32.327) enumeratig Game Devices...
[00:06:32.343](00:06:32.343) found Game Devices: 
[00:06:32.343](00:06:32.343) enumerating Midi Input Ports...
[00:06:32.343](00:06:32.343) found Midi Input Ports: 
[00:06:32.343](00:06:32.343) enumerating Midi Output Ports...
[00:06:32.343](00:06:32.343) found Midi Output Ports: "Microsoft GS Wavetable Synth"
[00:06:32.343](00:06:32.343) enumeratig TAPI Devices...
[00:06:32.343](00:06:32.343) found TAPI devices: 
[00:06:32.343](00:06:32.343) enumeratig Audio Renderer Devices...
[00:06:32.374](00:06:32.374) found Audio Renderer Devices: "Динамики (Realtek High Definiti","Default DirectSound Device","Default WaveOut Device","DirectSound: Динамики (Realtek High Definition Audio)"
[00:06:32.374](00:06:32.374) enumeratig Midi Renderer Devices...
[00:06:32.374](00:06:32.374) found Midi Renderer Devices: "Default MidiOut Device","Microsoft GS Wavetable Synth"
[00:06:32.374](00:06:32.374) enumeratig External Renderer Devices...
[00:06:32.374](00:06:32.374) found External Renderer Devices: 
[00:06:32.374](00:06:32.374) enumeratig Audio Input Devices...
[00:06:32.389](00:06:32.389) found Audio Input Devices: 
[00:06:32.389](00:06:32.389) enumeratig Video Input Devices...
[00:06:32.389](00:06:32.389) found Video Input Devices: 
[00:06:32.405](00:06:32.405) creating MainForm
[00:06:32.452](00:06:32.452) creating AddonHost
[00:06:37.584](00:06:37.584) vvvv caused error during startup: GetExportedValue cannot be called before prerequisite import 'VVVV.Hosting.Factories.StartableRegistry..ctor (Parameter="parentContainer", ContractName="System.ComponentModel.Composition.Hosting.CompositionContainer")' has been set.

win7 64bit, vvvv 45beta29, all boxes are green
same error in 45beta28

have you unzipped the file with 7zip? it might be a problem with file rights. also check your .NET installtion.

ok, second chance

no, there is no problem with rights

maybe problem in .NET 4.5 ?
as far I know, it replace 4.0 version, didn’t?

still: have you unzipped using 7zip? (the rights-problem is not user-visible and only expresses in errors like the one you posted). so make sure you try that.

here is someone with the same error as yours who claimed that a redownload helped: https://discourse.vvvv.org/t/8695

WOW! unzipped using 7zip and it works!
What kind of rights you talking about? I tried to manually add the “Full Access” for “All” (include sub elements) and it did not work…
very strange…maybe then it’s better to use the 7z archive instead of zip

i have the same problem as sternmull… after i installed pure-data extended (pd-extended 0.43), vvvv doesn’t start anymore. bevor that it worked great…and it is working when i rename the freeframes folder…
has anybody an idea?

qoooh, very strange, but please try with latest alpha. run crack.exe from there again and you probably have to install some more dependencies. hope that helps.

Thanks joreg! i’m on windows 7 x64 by the way…i tried the alpha builds 32bit and 64bit - 32bit still crashes, the 64 bit alpha version opens but crashes when i want to create an object…
but i figured out, that the 64bit beta version is working (i haven’t tried it before, sorry).
but still it seems that you can’t use the freeframes nodes in vvvv after installing pd.

indeed, there was a problem caused by the pd-installer, see: https://discourse.vvvv.org/

if you have a similar problem please test with latest alpha and if the problem persists for you start a new thread with your details.