VVVV Crashing at startup - Please help

Afternoon all;

I’ve today got my new laptop through the post which is obviously awesome.

Literally the first thing I’ve done is install Vvvv but it keeps crashing on startup.
I’ve installed all the .Net, DirectX and C++ stuff and it should be working.

I load Vvvv, but the little grey vvvv box (start box before a clean patch) hangs.

1ce or twice it’s I’ve actually got vvvv loaded, but the rest of the time is just hangs on the little loading box at the start and I’ve no idea why. It’s not like there’s anything else at all installed on this computer at the moment.

Any ideas?

Hey modified!

Wow - that’s odd. Especially on a brand new machine… Can you give us some specs? What kind of laptop do you have and what vvvversion are you trying to run? And I guess you ran the crack / setup.exe with admin rights? You can also look at the troubleshooting page. Running the /logstartup might help the devvvvs to figure out what’s going on if the problem persists.

Good luck!

did you unpack the downloaded zip-files using Windows built in unzip function? that some times cause the folders to be weied.
use 7-zip to extract the zip-files again.

Thanks for the quick replies folks.

I think I used winrar to unpack it, but I’ll try again with 7-zip and report back.

As for specs of machine:

Intel i5 2.6GHz
8gb RAM
Windows 7 64bit.

I was installing the 32bit version. I’m waiting for there to be more with the 64bit before trying that.

I have the 32bit installation on my other 64bit laptop and my 64bit desktop too.

So I’ve tried it with 7-zip and I’m still getting the same issues.
I ran the crack as administrator and all of the bits in it are showing green.

This is really strange and quite annoying.

Unfortunately I don’t know how to do the /logstartup.

shift + rightclick on the folder containing vvvv.exe

open commandline here (or something like that) then type

vvvv.exe /logstartup

Is .NET 4.5 and 4.5.1 installed?

Here is what I have on 7_x64

Thank you h99.

I’ve done the logstartup but I got an error message: Runtime error 217 at 0045317A.

I hit OK, the error box goes and that’s it.

.NET 4.5 is installed; I’m not sure about 4.5.1 though. I’ll install and report back.

Thank you for the quick and helpful advice :)

… Yes I do have .NET 4.5.1

Ok but you should post the log file, which is in the same folder of vvvv.exe here on the forum - 7zip it… ;)

OK cool, will do that and report back.

It’s not a downgrade. It was built fresh with only Windows 7 on it; I have the Win 7 disk, so can reinstall if needed. However this is quite literally the first time I’ve ever turned it on since it’s first install last week at the shop it was put together at (PC Specialist custom build).

What is the log file?

I’m assuming it’s vvvv.jdbg?

I googled the 217 Runtime error. It looks like it could be something to do with antivirus; I didn’t find any real clear answers on it (maybe my googleing isn’t up to scratch) but the general gist seemed to be issues with antivirus or a clogged registry; and I highly doubt that I’ve a clogged registry at the moment.

I have disabled the default (Bullgard) antivirus that came with the machine, but the issue persists.
It’s only a trial antivirus, so I may uninstall it and see if that helps any.

It’s something like 2014.05.13-19.00.00**.log**.
And, aehm, are you sure you have installed DX9, and not just unpacked the exe? In case you can download again, or if you find the dir where extracted files are you should double click on DXSETUP.exe

I’m 99.9% sure that I’ve DX9 installed.
I’ve attached a picture of the setup panel.

I’ve just downloaded it again from here: http://www.microsoft.com/en-us/download/details.aspx?id=35

When completing the installation I get the message:

“DirectX setup has determined that a newer or equivalent version of DirectX has been installed already. No installation necessary.”

There’s no logfile after doing the logstartup; just the usual folders and files.

Ok. I’m about rising hands on this.
Just please be sure to follow carefully these instructions, since something should be in vvvv.exe folder.
Or try to move the vvvv folder in another directory…

Will try vvvv in another directory now. It’s in my Program Files(x86) at the moment.

I’ve VVVV installed on 2 other machines and they’re both in the Program Files(x86) folder.

I’ve uninstalled the antivirus software but still no joy.

I’ll follow the above instructions and come back with how I get on.

OK so I’ve re-downloaded vvvv and put it in my user folder this time.

It’s still hanging on the start up; though this time I’ve managed to get a bit of a log file (attached).

The grey loading window is still on screen now at 20:40… I started the logstartup 7 minutes ago.

It looks like it’s hanging when scanning for externals.

2014.05.13-20.33.06.log_.7z (853 Bytes)

Ok, dig this


Nice one; thank you. I’ll check it out.

I’ve just downloaded the 64bit version of vvvv and installed that. This seemed to work absolutely fine.
I’ll run through the above thread and continue using 64bit until a solution is found.

I’m not exactly advanced in vvvv so I doubt less addons and such will have a great effect on what I’m doing at the moment.