Vvvv crashes on Microsoft Surface 2.0 (Samsung Sur40)

Starting vvvv on MS Surface 2.0 / Samsung Sur40 results in an instant crash.

Win 7 Pro 64 bit
AMD Athlon II x2 245 e Prozessor
AMD Radeon HD 6750M

crack.exe shows everything as OK.
Tested with beta27.1 and alpha27.2-f62d27da88

/logstartup returns the following (not that much)

[13:27:36.592](13:27:36.592) everything you know is wrong
[13:27:36.608](13:27:36.608) creating SplashScreen
[13:27:36.608](13:27:36.608) Adding lib\thirdparty to PATH.
[13:27:36.608](13:27:36.608) creating GClock
[13:27:36.623](13:27:36.623) creating GMainloop
[13:27:36.623](13:27:36.623) creating GLog
[13:27:36.623](13:27:36.623) creating GApplication
[13:27:36.623](13:27:36.623) creating GGlobals

enabling /logexceptions does not provide further information, no exception-dialog pops up.

The behaviour “can be simulated on a normal computer” by installing the Microsoft Surface 2.0 SDK (which requires Microsoft XNA Framework Redistributable 4.0)

After the installation start vvvv.
Then go to Start>All Programs>Microsoft Surface 2.0 SDK>Tools
And start the Input Simulator
–> vvvv crashes immediately.

Renderer TTY says:

00:88:13 - : HID (Human Interface Devices) 
Devicecontroller - OnDeviceChange

ai bjoern, it is /showexceptions not /logexceptions

and you’re saying vvvv startsup normally and only crashes when you start that surface simulator?

mh typo. I used /showexceptions.

Yes vvvv starts as expected but as soon as the simulator is launched vvvv crashes.

tried with older versions, works with betas up to 19.1. beta20 is the first one that crashes.

further investigation:

When starting the Input Simulator it in turn launches two instances of wisptis.exe and those seem to be the root of all evil. After killing the Input Simulator via Task Manager and leaving wisptis.exe alone, the problem still persists.
After that wisptis.exe can no longer be killed in the Task Manager, it always restarts. Even after a reboot the program is started automatically.

Seems this approach tricked Windows 7 into believing it´s running on a tablet PC. Suddenly I´ve got options/icons for Tablet PC Settings& Pen And Touch in my Control Panel.

VVVV (>beta19.1) now can´t be started at all.

How to get things running again:

Control Panel > Programs And Features > Turn Windows features on or off >

Change the state of Tablet PC Components, if it´s ticked, untick it or the other way round (this may require several restarts).

Open Device Manager, expand Human Interface Devices, look for Microsoft Surface Virtual Digitizer > right click > Disable (restart if necessary)

… no text …

aloha, pls try with latest alpha and report what tty spits out. i put some more log messages in the code in question and tried to catch the exception (if there is any).

TTY says:

00:00:55 - : HID (Human Interface Devices) Devicecontroller - OnDeviceChange
00:00:55   : OnDeviceChange: calling DeviceChangeBegin...
00:00:55   : OnDeviceChange: filling devicelist...

On the Sur40 itself I can get vvvv to run by disabling a certain HID-compliant device in the device manager that belongs to the Surface Vision Processor . Unfortunately this also makes the Surface a Non-Surface.

pls try again with latest alpha. i gave it some more infos…

TTY - using my Laptop and the Input Simulator:

00:00:28 - : HID (Human Interface Devices) Devicecontroller - OnDeviceChange
00:00:28   : Calling DeviceChangeBegin...
00:00:28   : Filling devicelist. Checked In: 5 Checked Out: 4
00:00:28   : Initializing
00:00:28   : Checking In: Surface Virtual Digitizer
00:00:28   : Initializing: Surface Virtual Digitizer
00:00:28   : Checking In: Apple Internal Keyboard
00:00:28   : Initializing: Apple Internal Keyboard
00:00:28   : Checking In: Touchpad
00:00:28   : Initializing: Touchpad
00:00:28   : Checking In: IR Receiver
00:00:28   : Initializing: IR Receiver

TTY - on the Sur40

00:00:41 - : HID (Human Interface Devices) Devicecontroller - OnDeviceChange
00:00:41   : Calling DeviceChangeBegin...
00:00:41   : Filling devicelist. Checked In: 5 Checked Out: 3
00:00:41   : Initializing
00:00:41   : Checking In: Vision Input Processor
00:00:41   : Initializing: Vision Input Processor
00:00:41   : Checking In: USB Keyboard
00:00:41   : Initializing: USB Keyboard
00:00:41   : Checking In: USB Keyboard
00:00:41   : Initializing: USB Keyboard
00:00:41   : Checking In: USB Keyboard
00:00:41   : Initializing: USB Keyboard

and once again please show me both outputs with latest alpha…

Input Simulator


aight, see, we’re getting there…again pls…

To much output to fit the window…

Input Simulator


…so about them buttons it is…
either output should be enough now…por favore…


how exciting…it is cornered…once more please…