Forum

VVVV crashes at startup

Hello,

I’ve been trying to install vvvv on a Windows 7 machine but as soon as I unzip the vvvv_45beta25.1 folder and try running vvvv, there’s an error box saying “Helo, sorry i cannot start. Please run crack.exe to see what my problem is.”. But when i run crack.exe it shows that everything is installed and fine. So i’m not sure what the problem is here. Any help would be much appreciated!

Thanks!

did you try to uncheck and check all checkboxes in crack.exe?

Yes I did… still no luck! :|

interesting one…

can you start vvvv with the startuplog? like so on a command prompt:
vvvv.exe /logstartup
that should create a .log file which you could post here.

Here’s the log file! Thanks for all the help.

Startup log file. (322 Bytes)

hm…doesn’t contain much. is that really all? was hoping for some more lines…

Experiencing the same issue here on 64bit win7. Crack.exe claims everything is good but the app crashes on startup. I get this with the latest build (45beta25.1) and earlier ones too.

Crash Log:
13:13:57.448 everything you know is wrong
13:13:57.481 creating SplashScreen
13:13:57.507 setting environment variable for opencv .dlls to \bin
13:13:57.507 creating GClock
13:13:57.521 creating GMainloop
13:13:57.522 creating GLog
13:13:57.522 creating GApplication
13:13:57.522 creating GGlobals

Windows Problem signature:
Problem Event Name: BEX
Application Name: vvvv.exe
Application Version: 4.5.25.1
Application Timestamp: 4d5da9b5
Fault Module Name: StackHash_e98d
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Offset: 00000000
Exception Code: c0000005
Exception Data: 00000008
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1033
Additional Information 1: e98d
Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
Additional Information 3: 6eab
Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583635

And from debugging in VS:
Unhandled exception at 0x00000000 in vvvv.exe: 0xC0000005: Access violation.
(Probably not that helpful)

@joreg,

sorry but that’s all there is in the log file! I know not too helpful. =\

see http://technet.microsoft.com/en-us/library/cc738483(WS.10).aspx

try turning it off for vvvv.exe and see if it helps. a description of how to turn it off is found at the bottom of the above mentioned article.

Turned it off and still crashing for me on startup. Crashing on another 64bit win7 machine I have here at the same point. Don’t know if it matters but XNA 4.0 and .Net 4.0 have already been installed on these machines (crash.exe claims that vvvv is good to go).

Just an update. I reinstalled windows, vvvv and the exact version of directx necessary and it runs fine now. I am guessing there is a issue with not having the exactly matching version of directx with vvvv. I had installed XNA and a couple versions of visual studio so perhaps that messed it up.

Same problem, dont know what to do with it, do i have to uninstall dx11?

helo guest,

no, don’t install dx11 or anything. please make sure to use latest vvvv (beta26 as of this writing) and attach your startup log here.

also you say “same problem” but it would help if you could specifically describe your situation again.

apparently, the problems began with 40beta23. i got an error message there (sadly i did not write it down) and with later releases, i got the same error like yours, but could not get rid of it. enabling logggin/debug did not give any hint.

for my curiousity, it disappeared after installing .net 3.5sp1 !!!

so, apparently vvvv is not a sane .net4 application as there may be left some reference to an older .net relase or .net4 api behaves different, as it should contain the api of the older .net releases !?

think someone should test a vvvv installation on a clean xp sp3 install with only .net4 and c++ runtime.

confirmed - after uninstalling .net 3.5sp1 i cannot start vvvv.exe anymore and it gives the above error. re-install 3.5sp1 and all is fine!

with .net4 my vvvv crashed when i added 3.5sp1 it started just fine!