Vvvv brings up an error after starting: Intel Message Catalog

Yesterday, vvvv was running fine, now I can’t start it anymore. A console window pops up with:

OMP: Warning #2: Cannot open message catalog “1031\libiomp5ui.dll”:
OMP: System error # 126: konnte nicht gefunden werden Das angegebene Modul wurde. OMP: System error #126: Could not find the specified module.
OMP: Info Nr. 3: Standard-Nachrichten verwendet werden. OMP: Info #3: Default messages will be used.
OMP: Error #15: Initializing libiomp5md.lib, but found libguide40.lib already initialized.

does anyone know what to do?

what i did inbetween:

  • installed GoPro Cineform Studio for Videocodec but already uninstalled again.
  • downloaded and installed vvvv 27 with all the .net and directx-updates, i was using 25 before.

andi hfg gmuend m-lab

Found this cannot-start-vvvv-omp-abort, which points here: https://discourse.vvvv.org/t/3941.
Hope is useful


thanks, i can now start vvvv with some error messages after removing opencv-dlls cv100.dll, cxcore100.dll and highgui100.dll.
but i don’t know where this error is comming from… -.-

so what are the errors you’re still getting?

.Net is telling me that these Files are missing, so yes, that’s true…

I have jsut installed vvvv_45beta27.1 and I am seeing the same error. Any advice? I do not think I have OpenCV in any form on this computer and also vvvv_45beta25.1 worked fine before.


To add. My error looks like that:

OMP: Error #15: Initializing libiomp5md.lib, but found libguide40.lib already initialized.

On the machine in trouble the search shows libiomp5md.lib in three different locations (two system folders and a Phase One/Media Pro 1 folder).

On my other machine that still has vvvv_45beta25.1 these files are in exactly the same places but all works.

So, this seems to be something to do with the latest release.

What is the advice please?

hei d72,

i am not aware of any change in b27.1 that would have caused this new behavior…have you tried if vvvv starts after removing the files avaos mentioned?

If I rename them, I get this error:

Clicking on this multiple time makes vvvv start. But something is still dodgy. Plus, my other programs do need this file, I presume…

And here is how it looks if I restore them:

Thanks for looking into this.

what did you rename? you were supposed to remove:

  • cv100.dll
  • cvaux100.dll
  • cxcore100.dll
  • highgui100.dll
    from \lib\thirdparty. this should make vvvv startup (even with some errors) and only missing some nodes of the DShow9 category…
    (and not touch the libiomp5md.dll which is obviously in use by other programs)

also first you could try setting the environment variable as mentioned in the screenshot you posted:

you can do so by opening a commandline, navigating to \vvvv_45beta27.1, typing:
and then running vvvv from that same command-line, by typing:

does that work?

Ah, I see. Thanks for correcting. I shall try this now but is it not trying to fix a basic problem by removing functionality?



leads to this:

If you click on this several times, vvvv does start…

Setting KMP_DULICATE_LIB_OK=TRUE does not change this.

ok, good.
of course this is not a final solution, but at least hopefully one you can work with at the moment.

as this rarely seems to happen this issue is of quite low priority. but probably switching to the most recent version of opencv will fix this one day.

Oh. :(

But how come b25 is working?

this i cannot explain…