VVVV.Audio Discussion

ambisonics ftw!
that’s great news - thanks tebjan!

Hi Tonfilm,

I’m trying to record some sound and play it back in quick sucession.

I get the following problem with the write(vaudio) node:

00:02:33 ERR : Could not find a part of the path ‘C:\Users\B\Desktop\Distopian Objects\Recordings\obj04\P02\audio.wav’.
00:02:33 ERR : Exception occured in TMPluginWrapperNode.Evaluate

and at other times:

00:05:11 ERR : Exception occured in TMPluginWrapperNode.Evaluate
00:05:11 ERR : The process cannot access the file ‘C:\Users\B\Desktop\Distopian Objects\Recordings\obj04\P02\audio.wav’ because it is being used by another process.

The first seems to occur when I try to play back a recorded file (it lets vvvv discover the .wav file when the recording has finished by pushing the filename string to the filestream’s pin, but it doesn’t play, despite the duration showing).

The latter error has been cropping up when I have tried to fix the problem by creating a delay between the end of the recording, changing the name that the writer sees, and pushing the string of the file just recorded. Is there a way to force the writer to unlock the written file quicker or smoother? Other .wav files fail to play too at the moment. They load into the filestream so I can see there duration, but they won’t play until I delete the writer node.

Any ideas?

'kay, I see that one of the problems was that the folder had to exist before the file could be written, so it would be useful if this could hapen automatically.

I’ll look into the second problem further, but it could be a domino effect of the above.

good point. i made an issue to check the folder before.

as for the other point, i have to think about a way to handle the file better… if the file would be released each time the recording stops, the file would be overwritten the next time. so the idea is that it will be kept open util the filename is changed. but maybe there is a better way…

How about defining a record folder.
Then you can have takes, eg. take #1, take #2 etc. when activating a recording. And then have the option to overwrite the file if you don’t want a bazillion files.

It could work a bit like writer (NRT) works with frame numbers

1 Like

Or like create an empty audio.wav file, write to a audio.raw file(hidden) and copy to the audio.wav once the recording is finished, with the audio.wav unlocked?

I think overwriting a file is ok. What do you see as the particular problem with that folks’ll have to just be careful about how they approach their work.

Hallo @tonfilm! Thank You for awesome VAudio pack! One question, plan you add import/export presets (.fxb files) in VSTHost node?

there is no plan on that, but basically the data that is saved inn the patch is the content of the .fxb. its a basic functinality, i agree… until i have implemented it you have the following options:

  • if the fxb files are produced inside inside the vst itself you can pack it into a subpatch and hit the save button. then copy and rename that file on disc. you can do this as often as you want and then switch the patches in vvvv.

  • use a meta vst plugin that can host other plugins, maybe one of them can load/safe .fxb files. List of VST plugins which can host other VST plugins

what plugin are you using and what are you doing with it?

Ok Thanks! I using Camomile, it PURE DATA VST inplementation. I want to keep the patch settings. I can save and load presets in fxb format in DAW such a reaper, but VSTHost and metaplugin not allow this. Can i correctly insert data from fxb file in .v4p file?

Just wanted to say great work tonfilm and everyone else contributing to this!

Reposting here since I think it might have gone unnoticed in the vvvveekend workshop posting plus addind some more:

It’s also worth noting that Windows 10 has improved support for audio a lot allowing you to achieve much lower latencies without any fancy hardware although I’m not sure it will automagically work all audio drivers and how much depends on audio software requesting dedicated audio thread. What I know is that I on a <€200 mini computer(including windows 10) can have 64 sample buffers (maybe even lower) running without problems, ASIO4all isn’t really needed either since you seem to get the same audio performance with WASAPI.

@tonfilm, i’d prefer if the audio file was released after downedge of [Write]. Pausing the recording should be a different pin, Allow overwrite could be a third one. As we are playing with user data that is on hard drive already and that contains “values of artistic performance”, it should be possible to avoid overwriting completely; maybe using a config. parameter == Visibility.OnlyInspektor.

Currently more important for me personally, however, is ability to write several channels in one file. The VST writer @sunep refers to scares my other pets to death.

tonfilm: Have you seen this library?

Came across it on stackoverflow with one user having experience of using it together with NAudio. Might be worth looking into what it provides that NAudio does not (I have only had a quick look so far)

hey beyon, the library looks very good in terms of codec support. the driver side not so much i am afraid. but it could help utilizing multiple soundcard outputs…


When i change sample rate to higher rate, i need to lower the bpm to get same speed?

on 44100 synth arpegiator play normal speed 180bpm
but on 192000 its x times faster

or am I missing something to set?


hi @barbarerik, usually not… only if your audio files have a different sampling rate. can you give more information about the patch that you build and where the speed changes when you change the sampling rate?

Ok it was probably broken VST synth, it also does distort whole system audio, i didn’t noticed since i was playing with noise sounds.
On Synth1 its work properly.

good morning

I was wondering if anybody has had the same problem:

I am playing back audio with the regular FileStream (VAudio) node (using AudioEndine and AudioOut obviously). Also I have a renderer window for some visual stuff.
Patchwise everything works fine, but I cannot record/screencapture it. Neither with Fraps nor Bandicam (demo version). I think I have tried every setting on the Bandicam sound panel and also in the ASIO4ALL control panel. ASIO4ALL seems to reserve the sound output for itself. Is this by design or am I missing a setting? Any ideas?

I am working on a simple Dell XPS laptop with no additional hardware attached.
thank you all

you need to record the audio seperately for now. best way is to use a VST recorder like MRecorder

@tonfilm Hello, I am using create/write/read buffers
Is there a way to clear a buffer?



you can just write zeroes into the buffer… or would that not work for you?