Forum

Vvvv_45beta24 bugs / questions

regarding shader/fx files and code editor:
those bugs (missing debug info, no recompile, etc) are confirmed, thanks for reporting them. we’ll look into it.

okay, cool :)

agreed.

hi devvvvs,
i tried svvvvitcher, and found that beattracker(bass audio) is missing in this new release

great work ;)))))

@screamer: afaik there were some licensing issues with the beattracker. (see https://discourse.vvvv.org/t/5825 )

also (crossposted from vvvv45beta24 ) wasn’t there supposed to be a “cons (ex9.geometry)” or did i somehow dream that one up?

cheers!
m4d

Great release,
The code editor make´s me want to learn c#

A question
Why are all plugins red?

thanks

Ari

Huh? That would mean that they’re all not working.

so whats left:

@granny:
confirmed: fx codecompletion does not show custom methods.
confirmed: codeeditor has troubles being hidden via ALT+3 twice in sequence

@sugoku:
confirmed: middleclick mainmenu doesn’t work on any plugin window (as the codeeditor simply is one.)

with your fiddling you hit our weak spot: .cs files saved with errors in them will not be recognized by vvvv on startup resulting in red nodes. as you noted the only way back is fixing the code in an external editor. that is not nice, we know.

@zepi:
confirmed: mousclick (instead of keyboard) after . pops an e.

@screamer:
whats missing is BeatTracker (DShow9) (due to as pointed out by m4d), BeatDetector (Bass) is still there.

@m4d:
good to hear you dreaming of new nodes. whats actually new though is Cons (Transform)

@lasal:
red nodes means that they are missing. either missing at all (did you get the addonpack?) or in the case of dynamic nodes they cannot be compiled (see above).

Since i updated today i only see the icon in the taskbar and nothing else.
before starting the updated version i renamd the vvvv folder on my desktop to vvvv(it was vvvv_40beta22 or 18).
i think i updated from the last version before this one. if i overwrite with vvvv_40beta22 it starts normally again.

Xp32 net3.5 sp1 and latest dx installed.

The log is attacched

2010.09.17-02.48.49.txt (4.4 kB)

helo bill,

looks all strange to me. you start beta24 from a directory called …beta22. while that shouldn’t matter i’d recommend you to simply do a fresh extract of the …beta24.zip to a new place on your disk and try again. start as admin once.

note that several versions of vvvv can coexist peacefully. no need to do directory renames and stuff.

the naming confusion it’s because i started to use vvvv with a old version and i kept the zip file name for the folder after updating, this time i wanted to get rid of the version number in the foldername also for future updates. i forgot to say that, yes, i tried to extract the files in another folder but it had the same result. now for istance i just tryed to update my netbook, also there renamed the folder to vvvv, and there it works… maybe is something broken about some dll with this os install :/ but it was working before the update :(

@joreg: thanks for the clarification. on second thought cons (transform) sounds like it has much more practical value than cons (ex9.geometry)… :)
really liking the release so far. not so sure if i am keen on the new node browser (maybe just takes some time to adjust), but the code editor feature is just sooo kickass! kudos to the devvvvs!

Awesome! I just noticed that there’s a new release. Thanks guys.
Immediately started to check it out and quite soon I stumbled over some bug.
Text(EX9) won’t be displayed in my renderer. Opening the text(ex9) help patch I’m just getting a blank green renderer window.
Maybe it has something to do with my graphics card? I’m running a Radeon x800gt.

yes, it’s time to come back home from a journey to c++.
next step cross-platform version ;)

epic

@rosenfranz, text needs latest directX 9.0c runtime and .NET 3.5 SP1, then start vvvv as admin… that should do it.

@ Joreg,

i´ve installed the addonpack and i have only problems with the plugin nodes not with the dynamic ones.

The last versions of vvvv are running propertly,

what happend?

thanks a lot

ari.

I´ve checked that only the Memo fluids, box2d, skeleton, chaos toys, metaballs, geometry plugins are not running,

Ari.

@sapo:
the main difference with beta24 is that it really requires .net3.5 SP1 to even start up. for beta23 .net2.0 was only needed when you used any of the plugins. so the problem could be with the .net3.5 SP1 installation.

@lasal:
so what you mean with those you listet don’t work? you can create them via nodebrowser but then they are red? memofluids and chaostoys are not in the pack, right? do you start them from the \plugins dir? can you try to open vvvv (without startup patch) and first thing you do is instantiating one of those plugins. are they still red?

@joreg
the red nodes are not in the browser, included the bass plugins.
when i put the plugins in the _root window are still red :P

thanks

@lasal
so the non-working plugins don’t show up in the nodebrowser. do you have the according .dlls in the \plugins dir?

  • when i put the plugins in the _root window are still red
    this sounds like you’re drag-dropping the .dlls from some dir else on a patch?

@Joreg
I have the plugins in the \plugins dir and i´m drag-dropping the .dlls from this directory.

ari