Vvvv_45beta24 bugs / questions

First: Nice update! I’m loving most of what I see. You guys rock - very hard :D

Now to the not-so-nice part:


Okay most bugs turned out to be me having missed something. But some remain:

You can hide the CodeEditor with ALT+3 only once. Open it again by rightclicking on the node and ALT+3 stops working. CTRL+W still works.

In any case closing the CodeEditor with CTRL+W does not delete the node.

If the latter is bug or feature I do not know. The first however seems to be a (small) bug.

I have an .fx file that exists both in my …\effects\ folder and in my working directory elsewhere. It appears twice now in the NodeBrowser (naturally). If I hover hover over the second one (the one in the working dir presumably) the tooltip will not follow.
From now on I cannot open nodes/patches from the dir the parent patch is in (even if I use another working dir) from the NodeBrowser. Typing their names or typing . yields the same error dialog, I pasted the debug info here: http://pastebin.com/KhmaC8Dr
Only rebooting my machine resolves this.
OpenInPatch does still work.

I’ll add more should I encounter more.


okay i have some questions about the FX-CodeEditor:
*Where can I find the debug information that I had before? There is no error-marking whatsoever… (and no menu)
*Also, when does the code get compiled? It doesn’t seem to auto-compile and I suspect it only recompiles on reloading the node/patch.

my middle click doesn’t work at all in the code editor or node browser (still fine in patches and inspektor)

was fiddling with the spray.cs

made a few modifications and saved each time, that worked.
when there was errors, they were cleanly displayed in the list at the bottom. and then i could re-edit and resave.

then did another big modification and saved, and vvvv crashed out (silently quit)
then reopened and Spray was a red node. Couldn’t right click on it.

The spray.cs file was still there (with my editions).

i made a new plugin with a template clone, pasted in the code from spray.cs and i got the errors
it turned out i was using ‘abs’ instead of ‘Math.Abs’ 4 times

had to use a text editor to put the fixed code into spray.cs, delete my new file (because it was using the same plugin name). then all back to normal

concerning the fx-code editor:
compile is ‘on save’ and if there is an error it will be show like before at the bottom of the editor.
middleclick does not (yet) exist in the code editor, but the code completion should display all methods.

i confirm. another workaround:
ALT-R for rootpatch, then rightclick Codeeditor-node. seems to work reliable.

i even can’t edit the fx!!!
buhuhu, for fx i want the old editor back…

but for sure the devvvvs know about that issue and sooooon…

if there is a ‘+’ beside the filename, its readonly. the effects in the release are marked readonly, that you don’t change them by accident. so go to node menu and make ctrl+enter or ctrl+click to clone one besides your patch…


I’m having no joy getting it to work on my 64bit Win7 machine, worked once, when I booted vvvv from a folder called vvvv_45beta24, I backed up my current version, then moved everything over from 45, to my main vvvv folder. I managed to get it to run once, but the spray module was red, showing dummy (vvvv) instead of the correct path, and dragging it in manually to link it up had no success… After this the new version isn’t working at all really. Just shows the splash screen, then sits in Task manager, never actually loading.

Note: Works fine on my laptop, which is 32bit win7. Is it still necessary to recreate the exe with MASM32 for 64 bit windows??

@tf: aaaaaaaaah! thx for explanation.

i never move immediately to a new Version…you now know why.

and they even announce it…

Yeah, I am back on my backed up version and working sweet, but was quite excited to use some of the new features! :) Well I can still play on the lappy!

did you start vvvv as administrator?

I cannot see that. If I open the editor all I have is a horizontal scrollbar at the bottom, but as soon as I make any modification that too vanishes.

It does display all the native methods. No custom methods however (if that’s what you mean with all methods).

Actually it’s a bit different. Once you closed it with ALT+3 you cannot close it the same way the second time. After closing it with CTRL+W you can close it with ALT+3 again. Go figure O_o

new version runs fine on my machine with win7 64bit. where’s your main vvvv folder? C:\Program Files (x86) ? i highly recommend installing it under your personal folder -> C:\Users\YOURNAME.

ok, now i got it.
for fx i am still not happy, but i can develop those still in beta23, not a problem. in general the codeeditor seems to be a good idea.

but there will be future improvements, i hope?

here is an other funny (small) one:
if I double click to make a node, then type “.” to bring up all available patches in v4’s directory and then choose one with the mouse (instead of the keyboard) I get a very polite error message by .NET
however, I guess the “.” isn’t needed from now on…
(I’m on windows7 64 bit, in case this is of any interest fo this issue)

and: hiding the plugin editor by alt+3 (once it is stuck) works again for me after pressing alt+1 (then alt+3 and the lovely fresh code-editor is hidden).

I didn’t meet any issues so far running my older patches on the new version. this is awesome!

@Elias Yeah, I have my VVVV folder on my D drive, just as d:\vvvv which is what I’ve always done as I keep all my visuals stuff on the same drive.

you said it worked once. where did you extract it? could you please try to extract it on your desktop and see if it works? my guess is you got some kind of permission problems.

@Elias Very interesting, did what you’ve suggested and that’s sorted it, haven’t tried putting in any of my modules, patches etc, but certainly getting VVVV to startup nicely is extremely positive! Will have to investigate further as to the permissions thing…

yes, just drop all your custom stuff in folder by folder, to see where it hangs… btw. the nodelist gets updated even if vvvv is running, we have a filewatcher on the directories now.

Any ideas why I don’t see the shader debug info? Can someone confirm this? Because I can’t really help with any further bug reporting right now because I have no real idea where to start experimenting…