Vmware fullscreen error please help!


I’m vvvv noob and am running it through windows xp (service pack 2) on a duel core intel macbook pro (256 nvidia graphics) through vmware.

any ex9 rendered patches set to fullscreen, produce a black screen my computer runs at 1440x900 resolution, I have tried this resolution and lower but have the same problem (although lower resolutions cause a black box in fullscreen mode, only setting the renderer to 1440x900 causes a fullscreen yet still black.

I have tried various different patches and am running dx9c (with the vmware 3d acceleration enabled) but cannot fix it, I can sometimes get the black screen to go either grey or sometimes white!

also once going back into the window mode the patch window no longer works and stays black and needs to be restarted.

I have downloaded the ex9 files but am unsure where to put them (i stuck it modules in vvvv root) but i am not sure that this will fix my problem, the patches work in window mode just not fullscreen!

any help would be amazing!

Rubicon R5A


the renderer has some “hidden” configuration pins.
you can access them only with an Inspector (CTRL-I)

look at “Fullscreen Dimensions”
its default value is 1024x768…

Hi Kalle its Rubicon (forgot my password!) thanks for the help but I’ve already checked with inspector, I’ve tried using my resoluion (1440x900) and lower res’.

When on a lower res and fullscreen it ressizes the window to the upper left of the screen to the dimensions of that resolution (say 104x768) but you can still see the desktop around it but as I said its just a black box or in 1440x900 a black screen (if thats any help) I have also fiddled with the other fullscreen options in inspector but nothing seems to affect it, whether its 1440x900, or the small screen window (in lower resolutions from what my mbp is set to.)

I was going to try using bootcamp instead of VMware but have decided not to as I dont want to corrupt my system and lose all of my work, so I really need it in VMware if its possible.

thanks again for you help this far.


hi its rubicon again, just for more info I have also tried using Dx9 patches as well as ex9. again changing the resolutin for the renderer inspector!


Don’t be surprised, what you are trying to do should work perfectly with BootCamp and a separate WIN partition. Doing this kind of stuff emulation based is prone to error, if working at all.