VL.CEF html texture example "overview stride" crashes

been playing arround with html textures in gamma. The latest release of CEF (VL.CEF…0.0.9) has an example for stride which makes gamma completely crash when I try to open it. I did instal the latest non-pre version before, but that one did not really work and gave me an error on the first renderer.

The skia example of the latest -pre release works fine. I just cannot play vimeo videos… but that might be a chromium issue. every thing else works perfect.

Did a quick test with vvvv gamma 2021.3.2 which worked fine. I installed VL.CEF-0.0.9-stride using the command

nuget install VL.CEF -pre -source nuget.org -source http://teamcity.vvvv.org/guestAuth/app/nuget/v1/FeedService.svc/

as outlined in the readme of https://github.com/vvvv/VL.CEF - did you install it in the same way?

Maybe another source of error could be that you have older versions of the package in your packages folder (Quad Menu -> Manage Nugets -> Show Installed)? To make sure maybe stop vvvv, rename the folder, start it up again and do the install as outlined above. If that still doesn’t work we’ll need to dig deeper. Otherwise it’s some kind of package conflict.

In case you’re wondering, I just uploaded a new version (0.1.0) which references VL 2021.3 so the special install instructions are no longer needed.

i renamed older nuget folders and installed latest 0.1.0 without any special command. Instal said everything was fine…
-> same crash happens unfortunatelly

I also checked some basic stride patches. Stride seems to be running fine.

Any kind of log you could provide? Maybe the windows event viewer has something useful?

But regarding playing videos. It seems that we need to update to a newer CEF version, however there’s a catch - when doing so we lose the feature of using a shared texture. So rendering 4K content can get slow again. Details to the why can be found here. And it doesn’t look good that this will come back anytime soon. So really wondering how to proceed.

yep. windows log. looks like some stride render handler and web renderer handler had an issue…?

Application: vvvv.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: SharpDX.SharpDXException
at SharpDX.Result.CheckError()
at SharpDX.Direct3D11.Device.OpenSharedResource(IntPtr, System.Guid, IntPtr ByRef)
at SharpDX.Direct3D11.Device.OpenSharedResource[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]
at VL.CEF.StrideRenderHandler.OnAcceleratedPaint(Xilium.CefGlue.CefPaintElementType, Xilium.CefGlue.CefRectangle[], IntPtr)
at VL.CEF.WebClient`1+RenderHandler[[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnAcceleratedPaint(Xilium.CefGlue.CefBrowser, Xilium.CefGlue.CefPaintElementType, Xilium.CefGlue.CefRectangle[], IntPtr)
at Xilium.CefGlue.CefRenderHandler.on_accelerated_paint(Xilium.CefGlue.Interop.cef_render_handler_t*, Xilium.CefGlue.Interop.cef_browser_t*, Xilium.CefGlue.CefPaintElementType, UIntPtr, Xilium.CefGlue.Interop.cef_rect_t*, Void*)

Hm ok, well let me try and cook up a version where one must opt in to the shared texture via an input pin. That way the node works for the common cases without forcing the user to the Skia version - the “render 4K textures with 60 FPS” case will be the exception then.

New version is up (0.1.1) which let’s you opt into the shared texture. Changing the pin you’ll need to restart your patch (F8/F5) to see any effect.
It should also no longer crash vvvv completely when enabling in your case. But I’ve really no idea why it won’t work for you. There’s not much we could do different in those lines of code. Probably a graphics driver issue?

what kind of GPU setup do you have? it sounds odd that it won’t support shared textures… you could try to update your drivers and check again.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.