VideoIn & VideoTexture YUV = grey instead of black


I have been fiddling and searching the forums for quite some time but didn’t find anything that could help me.

So here’s the problem:

I am using a videoIn node to get the video from my blackmagicDesign Card and use a videoTexture to process it further in my patch.

When I’m using the “normal” videoTexture, my video will lag or stutter. Everything else will be ok.

When I’m using the “new” videoTexture(YUV Mixing Mode), the video will play smoothly BUT it seems like vvvv is loosing some colorvalues as things that once were black appear now dark grey, white things appear britght grey and all the other colors are washed out.

It would be great if someone could help me with a workaround (shifting brightness & contrast isn’t the way I think).

I attached a patch that shows the problem (if you have a videoIn Driver installed)

if you’re on nvidia try in your driver settings:
Video -> Color Settings -> 2. With NVIDIA Settings -> Advanced
by default the dynamic range seems to be limited here which you can disable.

not sure if ati has something similar.

I am on nvidia and it worked. I still have to see if that resolves any lagging issues but until now everything seems to be fine.

Tank you so much!