VideoIn MediaFoundation not picking up any devices on exported app

I’m experiencing a problem when exporting an app with media foundation video input (just a webcam) where the exported app does not get any items on the video device list enum, in the patch however, everything works just fine, any ideas? thanks a lot!

Did you stop the patch while running the exe?

Make sure no other software is accessing the same camera.

Just double checked making sure vvvv is not running and issue prevails, camera is also closed and not being used while testing

Not really sure then. Did a quick export of the help patch with 5.2 and it worked fine.

1 Like

Ok so I did the same thing and it does indeed work with 5.2 , I guess the problem still exists on preview versions, I forgot to mention I was running 5.3 preview 168 , thanks a lot though, I think I can make it all work in 5.2 :)

Indeed, the something’s not right with the preview - will check, thanks.

I having the same problem. Only some specific cameras that don’t seem to need drivers are working. They’re being picked up differently from other apps. Same problem in Gamma 5.2 and 4.11 from testing.

@Hadasi i think this is a different problem and has something to do with the different backend that mediafoundation uses compared to the old WDM model.

Hmm, this via Stackoverflow:

Starting in Windows 7, Media Foundation automatically supports audio and video capture devices. For video, the device must provide a kernel streaming (KS) minidriver in the video capture category. Media Foundation uses the PnP path to enumerate the device. For audio, Media Foundation uses the Windows Multimedia Device (MMDevice) API to enumerate audio endpoint devices. If the device meets these criteria, there is no need to implement a custom media source.

However, you might want to implement a custom media source for some other type of device or other live data source. There are only a few differences between a live source and other media sources:

did a little diggin and found this blog with simple applications to list all your system devices and codecs:

on my machine, the MediaFoundation Transforms (MFT) don’t list my virtual webcams like OBS cam or NVIDIA broadcast. the blog also says:

Some of the transforms are dual, DMO/MFT, some are MFT only which make their useful functionality not available directly for DirectShow pipeline.

so i guess the devices not listed just don’t have a MFT but they do have a direct show driver. VVVV beta used direct show as far as i can tell. but i guess it is @Elias who really could shed some light on this, i’m just assuming…

edit: i just saw that this guy has some more tools to inspect available capabilities: Software – Fooling Around

this is correct.

1 Like

Forgot to mention, the originally reported issues should be addressed in latest. Just did an export with 186 and it worked nicely. Also see regarding video related changes.


Yes, i also forgot to mention it worked perfect with preview 185, checking out the new VL.Video in order to adapt the patches . Thanks a lot !