Video freezes vvvv

Hey everyone,

I have a strange problem with video playback from FileStream (DShow9) on a Quad. Everything works fine on my machine (XP SP2, Geforce 6200, Dualscreen), but on several other machines with similar setups vvvv freezes during playback. Sometimes it freezes after the first few frames, other times it plays perfect and freezes after a loop or two.

I can’t for the life of me figure out what the difference in the configuration is. Also, on those other machines I need to set VideoTexture to NonPow2 or I only see stripes and artifacts. I don’t need to do that on the working machine.
This only happens with the video playing… if I disconnect the FileStream video output pin and leave only the AudioOut node connected, I hear the file playing fine and looping endlessly.

I’ve fiddled around with the MainLoop settings, waitforframe, Boost… all to no effect. vvvv locks up and I need to kill the process.

I just updated the graphics drivers on all machines to Forceware 185.85, no change. DirectX version is exactly the same. And Renderer (TTY) doesn’t display any errors, all messages are just like on the working machine.
The other machines have a Geforce 7950 GX2 and Quadro FX 1600 M, respectively.

Any ideas what I could try?

yes, try another vidoe codec. whats your current codec?

Thanks for your reply.
I tried WMV3 and also an AVI with an ‘araw’ codec. Nothing. Thanks to your suggestion I tried an uncompressed AVI, and that works. Seems you’re right, it must be something with the codecs.

But they’re the same on all machines, and I just installed WMP 11 on all of them to make sure. I can’t wrap my head around this.

Okay, it seems to work with MPGs. That doesn’t solve my WMV problem, but it’s a step forward.

Thank you for the hint!

open the videos with gspot to see which decoder gets loaded. maybe you can find a difference at the mashines…

another hint is graphedit (to watch the directshow graph) and ffdshow tryouts