VAudio: Fraps does not record audio. Configuring Asio4All did not succeed


#1

Hello everybody. had previously used the DirectShow filestream in my patches. since I only patching in dx11 this is impractical. furthermore: fascinating possibilities. Asio4all and LoopBe1 have been installed for a long time. did a test and replaced the DirectShow filestream with that of VAudio. all good. but Fraps does not record any soundtrack! tried Asio4Allzu configure: without success. mangosh’s “IzpiIbiltzen” is in my pack folder. also runs under VAudio. there is the sound taken from Fraps. that´s confusing. there must be a solution. can someone help me? thanks


#2

sounds odd that you can record the audio from one patch but not from another. does it work if you copy the vvvvaudio_broh.v4p patch into your patch and play the music from there?


#3

I’ve only managed to record audio with vaudio through open broadcast studio, fraps has never worked for me


#4

only one application can access your asio4all driver at a time.

i dont know how it works exactly internally but i have used it enough to tell its not possible to record it with fraps.

Only programs that can handle asio well can record it.

with rewire for example you should be able to record the sound in ableton.

also good to know that it works with obs, as catweasel pointed out.