Using a serial input hardware


I’m trying to generate a motion graphic, ( or even to transform a string) according to an accelerometer that I have here.
It captures the movements (X, Y, Z) and sends to the computer through a serial port.
Is that possible? Can anybody give me some hints please?

Thanks in advance!


check out the RS232 Node.


Thank you man,

I was trying to use the Port (Devices) Node…
The port is okay, I’m also monitoring the port and is all good.
I’ve setted the write COM, Databits, Baud Rate and stop Bits, but still can’t detect it from the VVVV.


I haven’t used the port node but I think you have to have this installed. Failing that I’ve tended to use RS232 like readme. Be good to know how you get on.

Thanks Hadasi,

Yeah, I’ve tried, in the website it says -Windows 95/98/NT/2000/XP-, I’m with the windows seven, so I’m not sure if that’s the problem…
Anyway, I’m going to a windows XP computer now, to try it.

Hello you all,

Man, I really don’t know what’s happening… can anybody give me a hand?
That’s what I did so far:

  1. Checked if the serial port is really working
  2. Check the Baud Rate, Data Bits, Stop Bits and the Com port itself with a serial port monitor software
  3. Receiving all the data is ok.


  1. Create a RS232 node, and set the exactly same parametes and the same COM.
  2. Create a Port (Devices)( with the IO.DLL from the

But I just can’t see any changes in the nodes, I do know that all the data is been receipt from the device but I just can’t use or see it on the vvvv.

Is there some enlightened soul out there who could help me? [=

Is the output a null or is it just blank? Attaching a length node to the output should reveal this.

Is the “IsConnected” pin true to show that they’re talking to each other?

The other thing I wondered was whether you were running your serial reading software and vvvv at the same time. The only one piece of software can gain access to the port at a time.

It could be a permissions issue. Are you able to send data to a device using vvvv to detect that RS232 is working?


Hello Hadasi, thank you for answering;

The Output of RS232 is in blank, I’ve attached a lenght node and the count doesn’t change.

The IsConnected just sets to ‘1’ when I set the Enabled also to 1.
I was indeed using to softwares at the same time, but I’ve tried now with just the vvvv and I got the same thing.

I don’t know how i can use the vvvv to send data to the device ( the device is the Chronos ez430 clock of texas instruments I’m trying to use the accelerometer).
Any more ideas? Thank you man,really.


Well colour me baffled.

No OnData flickers received either?

Right, delete the Port node so you’re only using RS232. Make sure the device isn’t communicating with any other software.

There is a strong chance the device looks for a software intermediary to unlock data stream. All about the drivers. I’ve been using a device recently where this is the case.

If anyone here is familiar with C# there is a library they can write a plugin with. I’m not that seasoned yet and I haven’t got the device to test and debug with but maybe some around here with the skills will offer a hand. Its a useful bit of kit!

Barring that you can try a little workaround using this. It will send the data to vvvv as midi midiyoke or loopbe will be required too). Its not the prettiest solution but it should get you where you need to go.