uEye camera not working with ueye node from image pack

I began looking at the other files in the image pack, not sure if it is relevant, but the basics girlpower patch has CaptureProperty and VideoIn as red and throw the error:

Could not load file or assembly ‘VideoInputSharp, Version=1.0.4542.15384, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified.

And gives the log: https://www.dropbox.com/s/6f4u7rwqlgdpchq/vvvv.exe-exception-2016-11-30.log?dl=0

This happens on both my laptop and the installation machine

so, when this log message also appears on your notebook, it is unrelated to the ueye problem?+

iirc videoinputSharp is for imagepacks videoplayer (i guess this is x86 only… i don’t remember exactly)

Yes, it is unrelated to the ueye problem

So that didn’t make us much wiser.

maybe worth a try:

open ueye camera manager -> give cam another -> enter that id manually in the videoin plugin (before enabling it)

I don’t have ueye camera manager installed… I did install everything from the full download from here: https://en.ids-imaging.com/download-ueye-win64.html

not on any of the machines

that should install with the full driver…

it’s this tool https://de.ids-imaging.com/ids-camera-manager.html

Yes, it should, but it don’t

EDIT: I can’t find it anywhere in C:\Program Files\IDS\uEye

@sebl which version of the IDS software suite d you have installed?

I am now a bit wiser, it seems like the shortcut the installer makes in: “C:\ProgramData\Microsoft\Windows\Start Menu\Programs\IDS” does not survive a restart on windows 10, so it does not appear in the all programs list any more.

But it is still on it’s spot at “C:\Windows\System32\IdsCameraManager.exe”

EDIT: changed the link to where the file actually is, which is also what @sebl wrote after this post was first made

ids camera manager is here C:\Windows\System32\IdsCameraManager.exe

(don’t ask me why it’s here and why windows search doesn’t find it properly)

changing the ID of the camera does not seem to make any difference

i have no more ideas…

i just downloaded the freshest alpha x64 incl. addonpack (d95355abd7) and the pack from the contribution. it works out of the box on my machine.

maybe one of those 2 things:

  • the folderin the zip is named ÎmagePack (which is a stupid typo) and i fixed that to ImagePack.
  • i used VideoIn (uEye) help 2.v4p instead of VideoIn (uEye) help .v4p

my specs are:

  • W10 1607
  • gpu is 580 GTX
  • cpu is i7 980
  • latest ueye driver installed
  • nvidia driver is 373.06
1 Like

ok, i could reproduce the problem today on another computer…

the problem seems to be related to nvcuda.dll (which is also a hot topic on the contribution page).
so, @sunep, is a difference between those 2 comps you have, that the one that’s working has a nvidia card and the other doesn’t? if yes, copy the nvcuda.dll from the dependencies/x86 folder to system32/

i guess it’ll also work if you install the nvidia driver.

I’m not sure what’s going on there… the points i learned are:

  • emgucv2.4.2 (which is used atm) relies on nvCuda.dll since it is compiled with gpu-support
  • normally the nvcuda.dll is in Dependencies/x86 folder of the imagepack. but this seems not mandatory, because it worked without on my notebook.
  • i guess, the dll mus be somewhere in path or vvvv finds it on its own (wink over to the dependency-hell topic)

so, for now i think it’s best to mess around with the dll(s) until it works. but long-term solutions for the imagepack could be:

  • switch to a higher emgucv version that has gpu-support optionally (@mino talks 2.4.10 on the contribution page)
  • use nugets (instead of static linked dlls) if there are any available
  • make emgucv a submodule of the imagepack

Yes, the difference is built intel GPU vs. nvidia GPU

I don’t have a “dependencies/x86” folder in, I assume: “ImagePack\nodes\plugins\Dependencies” in any case there is no file with cuda in its name anywhere in the ImagePack besides one named: “cudart32_42_9.dll”

I do have a nvcuda.dll in my system32 folder on my laptop, it does not work copying it over to system32 on the machine with no nvidia GPU

I am a bit confused

I am running Win10 64 with beta34.2_x86.
trying VVVV.Packs.Image-sebl_beta43.2 with nvcuda.dll inside node>plugins> Dependencies
no success
ueye driver 480

Hey sebl! I got it run with beta 35x64. Right after install “ÎmagePack”. Thanks!
will test it intensively later on.
not sure how to get it in x86?
with VVVV.Packs.Image-sebl_beta43.2 installed I get red nodes in help patch.

I am able to run on two machines: one with win7 another one with win10, both with Nvidia card.
But I can’t get it work with Win10 and ATI card. I am using beta35x64 with IDS software 4.81
with nvcuda.dll in dependencies/opencv/x86 and system32 as well.
the node gives me error message: Der Typeninitialisierer für “Emgu.CV.CvInvoke” hat eine Ausnahme verursacht"

any suggestions?
edit: OK it has probably nothing to do with ueye node specifically and seems to be related to OpenCV and AMD card problem.

can you try the same with b35x86?

I’ve tried x86. Full of red nodes. But it was really AMD card problem. I replaced Fury with my old GTX 670 and all gets good

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.