UDP / OSC problem


It’s again me having a question. sorry but working on a project with a lot of new tasks.
I try to receive OSC messages coming from node.js in v4. but I don’t get any input. the UDP server node is listening to port 3334, which is the port the messages are sent to (localhost). but there is nothing coming in at all through the UDP node. max/msp has no problem to receive the UDP messages. what is strange is that it was working once but I don’t know why. I thought it was due to setting the Queue Mode of the UDP node to “Spread”. But if I do it now again it does not change anyhting. I used the helppatch and made an own patch but still nothing is happening (only one UDP node at all in the patch). As I said with Max it is fine immediatley and all the time. And of course I did not run Max and v4 at the same time so v4 should be able to bind to the port…



hei darr, it is hard to smell whats going wrong there. can you upload a patch that demonstrates the problem?

instead of receiving data from nodejs you could also, just for a test, send data from a UDP (Network Client) node in the same patch to your receiver and see if that works at all.

also if you haven’t already, take a look at the udp/osc overviews here:


thanks for replying. sorry that I did not upload anything but basically i’m just using the help patch. sending and receiving UDP within v4 is fine. and I checked everything within girlpower. so it’s about receiving from node.js. I attached fotos to demonstrate what’s going on. hope that helps:

The Editor (upper left) shows the init of the client on the website (websocket). the commandline below shows the running bridge.js (OSC through node.js). the website (lower right) shows the site itself with two buttons. with an onmousedown event they ‘emit’ a OSC message ("/provinz" & “/regional”). the max window (upper right) shows the very simple patch that can handle the sent messages without any issue. if I press the “provinzkunst” button in the browser I get a bang in max. but not in v4 (and as I said I shut down max before I tried, v4 should be able to bind to port).

please still upload your patch.

… no text …

osc in from web.v4p (11.3 kB)

now i see. just choose a different port than 3333, 3334 and 3335 as those are used internally by vvvv as mentioned here: commandline parameters and here: boygrouping basics#which network ports does boygrouping use

note to self: enable error output on udp nodes!

check: UDP (Network Server) now has a Status output

I too seem to be having udp server problems, in that they sometimes work and sometimes don;t and sometimes never work. Is the UDP status only in the alpha modules?

guest, jes status output for now only in alpha versions.