Tuio Trouble

I’ve been having some problems with receiving TUIO, I’m using tbeta, tried 0.3 and 0.4, and vvvv versions 21-24, also reactivision, at best I get 3 or 4 blobs from 8-10 in the tracker, arriving from the TUIo plugin, at worst I get none. I can see the bundles in the UDP node, but I get the impression that they are incomplete, I’ve tried throttling main loop, setting the UDP discard/spread/con, any other suggestions or recommended settings?
Funny thing is when I initially tried this, it all worked, but now none of my pc’s seem to like it


i just guess something:
do you use IOBox (String)s somewhere for the received data?
try to avoid those.

rendering the text into vvvv’s UI costs some performance which may cause drops in rare cases.
had this experience with ~20kBytes of XML which i received via UDP.

after changing to S (String),R (String) to pass those data between patches i didn’t have those problems anymore.

perhaps IOBox (String) should get a Show Value to disable rendering (like IOBox (Value Advanced) or IOBox (Color) ).

No its not that, tests are with just a udp node and TUIO decoder and value io’s on the output of the decoder… all done on 1 pc via address, really shouldn;t be loosing network data should it?

hhhhm another wild guess:
playing with Mainloop and/or Boost (VVVV) ??

heres a screenshot of the test patch, you can see tuio bundles (I’ve separated on #)
From the udp node, but tuio plugin outputs null.
Is there a way to view the tuio string in a more verbose fashion, rather than a series of squares? The only character that changes is the last one, which seems to count through from 0-256, which I presume are id’s? where should the x,y co-ords be? I’d make a patch to get them if I could see them!
Any help would be appreciated (using tbeta 1.4 )

Update, I’ve just tried it with the TUIO simulator from reactivision, and it works as expected, so there seems to be an issue with ccv and vvvv, is noone else using ccv, or do you not have these problems? (41.0 kB)

I’ve started using CCV recently and hit the exact same problem, I only receive a small number of the tracked points in vvvv.

Anyone figured this out?