Forum

Troubles of glitches/little freeze with DX11 DOPE and PreparGraph

Hi, i m experiencing glitches with bezier paths for animation while using DX11 and D.O.P.E and vvvv 50beta37x86 .

i m on a small computer with intel graphics 560 ( a surface pro 4, with SSD), wich works uselly quite nicely.

Here is a little sample, and just with this simple sample ( having a DOPE sample running and a Point running along a bezier path for animation) i m experiencing random freezes for the animation along the bezier path, with big upload on prepargraph.

any help will be greately appreciated !!! :)

Troubles.zip (25.1 KB)

Well any laptop will have limited amount of bandwidth between processes or and hardware, i’ll check tomorrow your patch on hi-end desktop machine and let you know if there are any lags

thank you antokhio. this happens only with dx11 use…

salut Christof!
tested your patch on surface pro 4 i5 6300U (18-20% cpu load)
beta 37 x64
dx11 x64 1.3.1 (2018-06-02)
no glitch
charles

Hi charles and thank you. hum… what could it be…

did you check the windows power managment options?

no, wich part exactly ?

In Power options
You my try to Set it to high performance?

i dont have any access to high performance mode. this glitch thing happen also on another laptop. especillay if i load a little bit the patch with other things
the projection is set on 1/3rd of the screen, so a little glitch became visually a big glitch :)

Founded !
System > adavanced system settings > performances
Thank you Charles !

Finally , this trouble continues… woaw

Big fat spikes in prepareGraph usually (at least multiple times for me last year) speak for garbage collection problems. You might wanna check if those spikes correlate with the counter of Gen 2 collection increasing via Process Explorer.
If yes, finding the culprit is tricky… don’t know any decent debugging methods for that, so I usually just remove nodes that seem suspicious till it stops freezing. Example would be a SegmentZ nodes with its resolution set too high.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.