Troubles changing from arduino UNO to arduino Micro

using node rs232 with arduino UNO, it works great. but with arduino Micro it doesn’t receive data. nothing is changed, except the COM port. before it was COM24, and now it’s COM28, but I’ve setted it both in arduino and vvvv.
there are other settings that I should be change?


Do you get any Data in the serial monitor of the Arduino software?

There are some differences and tips stated in this list:


in vvvv there are no settings i know of, that need to be changed apart from the COM port.

as the arduino micro is based on the leonardo there is this special “feature”:

Since the boards do not have a dedicated chip to handle serial communication, it means that the serial port is virtual – it’s a software routine, both on your operating system, and on the board itself. Just as your computer creates an instance of the serial port driver when you plug in any Arduino, the Leonardo/Micro creates a serial instance whenever it runs its bootloader. The board is an instance of USB’s Connected Device Class (CDC) driver.

check this site for further information:

it seems like you need to include a line like

while (!Serial) 
    ; // wait for serial port to connect. Needed for Leonardo only

after your begin.Serial statement…
forum discussion:

hi westbam, the serial monitors works right. the problem is that vvvv doesn’t recive data. but with arduino uno does.

hi soriak, I have seen that post in arduino forum. I’ve tried the “while (!Serial)” and the other solution proposed in that post but it still doesn’t work. I’ve wrote a message to empero asking if he finally had found a solution. I hope he will answer.
if I don’t find a solution, a way could be buy an arduino mini? (I need a small board). Or there is something different from arduino uno also on the arduino mini?

thank you!!

hm, that’s rather strange…
did you also try to use the Serial1.print instead of Serial.print ?!
i don’t have a micro here, so i’m not sure where the problem might be…

If the Serial1 thing doesn’t work either: I like the arduino nano, it’s the arduino uno in small. same chipset, same everything.

Hey, is this still an issue?

would like to use a arduino micro ( cheap knock off )

Go Teensy instead.

No, it doesn't run on an Atmel, but it feels like the bravest Arduino. While it runs on 3.3V, it can handle 5V on pins.

In fact, it has so much more potential. Better bootloader, that does not require you to break connection before uploading. More pins with more versatility, much more RAM, a lot more speed. Multiple serial ports, multiple I²C, CAN out of the box are other features you get with the Teensy.
Don’t stop there: add a battery and a quartz and you added system time to it. Add a Wiz820io and you have networking. Add a SD and you got a hard drive. Breakouts to adapt are widely available, and code to make it all run is free.

totally agree with @velcrome. the only downside of the teensy is the higher power consumption (which might be a concern when running it of a battery).

Hey thanks for the infos! i will def try teensy. its sounds great. Any cool projects/ guides i should see/read?

However i already had ordered the following:

Nano V3 | Entwicklerboard für Arduino IDE | ATMEL ATmega328P AVR Mikrocontroller | CH340-Chip at the rediculous price of 6,50€ and can confirm it works without any problems with vvvv and firmata after setting it up.

Hi guys,
I’ve struggled with the same problem and just find a solution to the issue.
Checking the “RTS Enable” (Request To Send) toggle on the RS-232 node I’m able to share data between VVVV and Arduino!


Hope this can help.