Trouble getting Kinect to work on W7 64bit


i tried several time with different combinations of versions and patches but can’t get the kinect to work. I’m running W7 64bit and tried both the 25 and 26 betas.

So i wonder what the correct configuration is …

do i need to use the stable or unstable releases of OpenNI and Nite ? 32 or 64bit ? Dev or Redist ?

Should i use the SensorKinect from the ‘Demonstrator’ folder or the one from the avin2 release (Which only works with the unstable OpenNI 1.4.2).

I tried out many combinations (i always uninsztalled OpneNI, Nite and SensorKinect before installing another version) and with the 32bit unstable the OpenNI Simpleviewer worked briefly in V i could start the Demonstrator patch, the kinect image briefly appeared but then the window froze after 5sec.

With the 64bit unstable release the OpenNI SImpleviewer doesn’t work at all and the V patch i don’t get red nodes but the kinect viewer window is just white.

What am i missing ? I tried almost every variation i could find and think of, first following this thread: openni-plugin and then trying every possible combination i found in the comments andother threads.

The 64bit drivers didn’t work for me either.

Am using the 32bit ones successfully on win6 x64

Using -

openni win32 redist
nite win32 redist
sensor kinect win32

i managed to get it to work, sort of, with the 64bit-dev drivers and i see the kinect signal in the OpenNI viewer, but the viewer crashes after a couple of minutes if i let it sit alone, or after a few seconds if i do sth with the mouse.
Will try again with the list you gave me now …

a simple trick to install drivers kinect … install the trial so touch air … it automatically installs the versions, then uninstall the app if you want to so touch air