Forum

Transparent background in images

If you are using dx11 nodes you have to connect Blend node set to blend to the group or the layer.

The alpha blending by default is disabled in dx11

in vvvv beta with dx9 and vvvv gamma with skia, transparency in images is supposed to work out of the box. if it doesn’t work for you, please upload a patch and image that demonstrates your problem.

thank you for your answers (a while ago). i tried to safe the images in photoshop again, option “safe for web”, png-24 including transparency. it didn’t change, the problem still exists. here’s a section of the patch. below all images are connected through a group node.
and then a snippet of the overlapping pics.
now it is only about gamma btw, i keep working there…

if this is the solution: where should i put blend mode node?

as i am very new with v4: what means dx11?

snippet of rendered images, overlapping

This going to make joreg very happy.

DX11 is a set of nodes available for vvvv beta.

@maike.zazie indeed it seems that some .pngs don’t work. others do. we haven’t found a difference yet. can you upload one of yours here for us to investigate?

@joreg but now it seems to have been transformed to a jpg…

indeed… hm… maybe the forum upload does that. if you zip the file and upload the zip?

@joreg

it wasn’t possible to upload a zip here…

if I import the wal.png into affinity photo and export again as png (02.png) the background becomes transparent

2 Likes

02.zip (986.1 KB)

1 Like

@joreg do you have a solution without using affinity photo? in general i would like to know why it doesn’t work with photoshop resp. how it does. & for now i can use the demo version of affinity photo, but if possible i would like not to be forced to buy a second graphic program for the future only for this problem… and i suppose it should work without…?!

@envoy GREAT. Many thanks <3 I will try this with all the other images as well. Very happy to be able to go on working on this

@maike.zazie absolutely. this will be fixed. we’re still investigating though to understand the problem…

1 Like

Yippie. At least for now I solved it & can go further working on it :) I tried your way @envoy via affinity photo and it worked. every background is transparent.

@maike.zazie this is now fixed in latest previews.

3 Likes

@joreg great! a nikolaus present from vvvv :) many thanks

1 Like