Track Bodies of Devices.AzureKenect.Body on Gamma 2021.3.0


Does it work for everyone to use Azure Kinect for Body tracking with Devices.AzureKenect.Body?

I open the Track Bodies file and it does not work on my Gamma 2021.3.0.

The point cloud example does work properly, and I know Devices.AzureKenect and Devices.AzureKenect.Body are using different nugets.

Thank you and look forward to any suggestions in advance.


i just tried this with 2021.3 and VL.Devices.AzureKinect.Body 1.2.1 and it works out of the box. can you be a bit more specific about the problem you see?

Hi @joreg,

Thanks for checking.

The image below is what I have. I believe the VL.Devices.AzureKinect.Body 1.2.1 has been installed. But when I open up the Track Bodies file, it just not shows anything. And my Azure Kinect will not turn on.

I tried to refer to this post here, but didn’t seem to get the answer. Do I have to take certain steps for this?

One other question is I’ve managed to make Azure Kinect point cloud to VR. Do you know how to extract the color of the Azure Kinect Depth camera? Do you have that feature already within the AzureKinect device component? It would be great if you can give me some ideas/suggestions.

Thank you so much for your help in advance. I am really looking forward to using VVVV more in this direction.

Have a good one.


A bit more about my computer system:

Alienware Aurora R8
Processer: Inter® Core™ i9-9900 CPU @ 3.10 GHZ
Install RAM: 32.0GB
Graphic Card: NVIDIA GForce RTX 2080 SUPER / Intel® UHD Graphics 630

that is odd indeed. it all looks correct. do you have a chance to test this on a different PC?

Hi @joreg,

I took your advice and try on my other Dell laptop(Precision 5530), but unfortunately, it didn’t work on that machine as well.

In this post, you’ve mentioned to manually remove Microsoft.Azure.Kinect.BodyTracking from nuget: AppData\Local\vvvv\gamma\nugets before installing the body tracking nuget, do I have to do so? But I cannot find the exact Microsoft.Azure.Kinect.BodyTracking you mentioned.

BTW, do you also know the way to show the color of the Azure Kinect Camera?

Thank you so much for checking out this issue for me.

Look forward to your reply soon.

Have a good one.


Sorry forget to mention one thing.
While open up the “Track Bodies” file, the Kinect will be on in a second and turn off immediately.

Thank you!

I think I found the problem.

For my other Dell, I didn’t update the Azure Kinect Body Tracking SDK, and I didn’t install the SDK for my Alienware Aurora. (It’s weird because I can still use those Azure Kinect Viewer and Body tracking viewer).

After I installed the latest SDK from here (Azure Kinect Body Tracking SDK), then it works.

Sorry for bothering with the questions.

BTW, do you know how to capture the color for the point cloud through your AzureKinect device component?

Thank you so much.

Have a good one.


good find. i wouldn’t have thought we need the SDK installed…

re your pointcloud/color question please start a new topic.

Hi @joreg,

Yes, who have thought. Unless I came out with a solution.
Thank you for keep checking with me.

And I will make another post regarding the point cloud/color question.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.