ToggleButton (GUI/GUI Multitouch) bugs

Hi vvvvusers,
I found a bug inside ToggleButton (GUI Multitouch). If the number of buttons is even everything works but if the number of buttons is odd you notice a strange behavior.

Working with b29.2_x86.

Please, look at the attached patch.

ToggleButton (GUI Multitouch) help_bug.v4p (24.7 kB)

the bug is strange indeed.

but can you use the normal ToggleButton node for your purpose? since two betas it can handle multitouch as well.

I would use ToggleButton (GUI Multitouch) because I have to connect Tuio decoder. ToggleButton (GUI) accepts only MouseState. Is it right?

yes, thats true… but there is a join node for MouseState…

I tried to connect MouseState (System Join) to ToggleButton (GUI) and spread it to simulate Tuio decoder but it doesn’t work as expected. Where I’m wrong?

ToggleButton (GUI) help_mod.v4p (21.1 kB)

interesting, looks like another bug… i will investigate.

had the same one today. but i was unable to reproduce it… node went red, when resetted (set value)

Ahhhh! 2 bugs in 2 similar nodes! Panic! :) I wait for devvvv solutions…

are there news about ToggleButtonS bugs? I need a solution for some multitouch tests… thanks!

hello Alec,

i am currently working on another task and will take a two week holiday tomorrow. the bugs look not trivial, i will have time for it after the 18th april. hope you can wait util then. if not you could ask any programmer to find the bug, the code is part of the addonpack and open source…


funnily today i stumbled into the same bug, searched the forum and found this here :)

tebjan, please keep us updated. i’m desperately needing a spreaded mouse state with the buttons.
thank you!

yes, it’s still on my todo list. i will be back on my desk tomorrow, but i can’t promise that it’s the first thing to work on.

this is delayed another week, much sorry!

multitouch mode still not working, needs a proper rewrite. for now please split the mouse states and use the ones from vux and make sure you have an even number of slices…