Forum

Texture problems vertex buffer


#1

Hi.

I´m working in a composition with a xfile textured mesh, but when i decompose it with vertex buffer the texture (and the object) is not visible and i must to turn off it.

There is any way to fix it? i´ve tried with differents shaders, phong directional, gouraud, etc, but nothing.

Thanks a lot ;)


#2

hallo???.. no text …


#3

i don’t know too much about vertex buffers, but it may help if you post your patch so we can see what’s wrong ;-)


#4

yes, please post a patch…


#5

Hey!! thanks for asking.

This is a very simple composition with a textured model, made in modo 302.

danke ;)


#6

I´ve fixed it!!!
this is the link

http://www.megaupload.com/?d=NE1HDS90

thanks for your help


#7

I didn´t find any way to upload files, is a bug?
I´ve attached them in 2 last post …

There is any post about it?

Sorry and thanks for your time


#8

I’m sure your mesh exceed the maximum vvvviki’s file size…

Anyways try a recompilation of your splitted vertexbuffer before goin’ into a shader and connect the texture coordinates pin of the joined vertex buffer___


#9

I´ve tried it with a simple sphere and didn´t run.

Do you have a example of this recompilation of the vertex?

thanks


#10

when decomposing the mesh, did you take care of passing the texturecoordinates?
by default the texcoord pin on the vertexbuffer (split) node is hidden.


#11

Thanks a lot for the asking, i´m going to try it.

Other thing, anybody knows how can i upload my patch in the comments???

Thanks


#12

Finally i´ve decided upload it in megaupload, this is not a cool solution but…

thanks ;)

http://www.megaupload.com/?d=HE2XLOQ3


#13

I´ve fixed it !!!
this is the link

thanks :)

http://www.megaupload.com/?d=NE1HDS90