Text(EX9) Bug?


i have some trouble with the Text(EX9) PlugIn and (some) Fonts. It shows cryptographic stuff - the Caps as small letters - and so on. It seems that the whole Font-Table is shifted to nowhere. (doesnt matter which font encoding is selected)
The Font itself works well in other Applications and with Text(DX9) and Text(GDI) Nodes too. (as you can see in the attached image)

i already tried to convert the font to another format but it doesnt help.

anyone any ideas?

seems it doesnt work with .afm-format properly

convert it to .otf with crossfont http://www.asy.com/scrcf.htm (trialversion) this should do it :)

hm not really a workaround. would be better to take a closer look to the c# text functions…

was fiddling around the plugin code without any success.
incoming strings seem alright until they’re passed to the (slim)dx font render function.

milo was guess was right with the font table shifting. did’t find a logic where its shifed to though.

welcome to try the patch and report findings.
spacing will stay fuckd though

postscriptTrouble.v4p (7.7 kB)

same fiddling - same result for me.
meanwhile i converted the whole fontset to otf via crossfont. that works (for the most styles).