Tdt, dtt, dttv?

Yes it would be quite beneficial - here’s some food for thought.

It doesn’t happen to me…

I managed to setup VLC player so that it streamed my DVB-T.

Then I connected to this mmsh stream, and had it playing for about 10 seconds.

Then unfortunately my (XP laptop) crashed, but I had seen BSOD’s before when trying to decode DVB-T from within the plugin, and sometimes from VLC player, so I guess that might be a local issue with this freecom DVB-T stick or something.

What system are you working on? could you attach a simple patch that I could try myself?

I ve tried on 2 W7-64 machines, the DVB adapter is this one:

as for the patch, really nothing special, the vlc plugin attached to a quad and a renderer.
The string:



What happens if you enable transcoding when streaming in VLC player?

If this works and you’re lucky, maybe simply selecting another container format without transcoding might do the trick?

On this page at the bottom ( they speak about the options ‘programs’, ‘program’, ‘sout-all’. I don’t know what the default beheviour is, but using this somehow to make sure there’s only one video and one audio channel being streamed, might help?

I’m running out of ideas, but I do believe it should be possible. Apart from crashing after a few seconds, it worked over here, so…

In worst case you could still use a normal capture device and a hardware receiver? Sure thats not elegant and indeed it a pitty that you can’t get mpeg2 transport stream into vvvv, just in case you need it working soon.

taking advantage of the topic … Anyone know a video converter composite to SDI …
Here in Brazil it is difficult …

Hallo, still no working, I ve tried different transcoding options but the VLC plugin always opens a new Direct3D window.


I finally found a workaround that works here (I installed the DVB-T stick drivers on a Windows 7 32bit laptop).

(I can confirm that it also opens another window here, if I try to open the DVB-T stream in the plugin)

What I did was: stream the DVB-T stream from VLC player (mmsh, but http might work also), but activate ‘transcode’.

I selected ‘Encapsulate as MP4/MOV’, and I transcoded the video stream to M-JPG (8000kb/S, if you leave that setting at 0, quality isn’t great).
For audio codec, I selected keep original audio stream.

I know this adds some useless transcoding, but it works, and the core i5 processor in this laptop doesn’t seem to have a problem with it.

Ok some more info, and a fix!

First of all, this is how I use it (you can select the program like this, but you need to know the nr, I found it by looking in VLC player’s menu, before the menu showed strings instead of the numbers :)

dvb-t://frequency=506000000:bandwidth=8 | programs=4144

The problem was, that LibVLC first reported only the audio stream, and some time later it reported the video stream also, but by that time I had already setup everything for audio-only.

So now, whenever it tells me there is a stream detected, and the filename starts with dvb-, I wait a few seconds longer, and check again how many streams there are. By that time, it reports the video streams too, and everything works as it should.

So go check in Contributions, as I will upload a new plugin that should behave correctly for DVB- streams…

Please let me know how it goes on your end.


Yes ! yes ! yes !

I can t get the programs to change. When I append the" | programs=xxx" string the stream will load only if the programs number exists but won t change a different program, it always choose the same one.
Ex. let s say that the programs number are 45, 46 , 47; if I use

dvb-t://frequency=490000000:bandwidth=8 | program:46


dvb-t://frequency=490000000:bandwidth=8 | program:47


dvb-t://frequency=490000000:bandwidth=8 | program:48

it will always load the same program, but if I load

dvb-t://frequency=490000000:bandwidth=8 | program:50

then it won t load the frequency at all.

Another problem is that I am not able to add the deinterlacing filter, I d expect the string to be

dvb-t://frequency=490000000:bandwidth=8 | program:343 --filter-deinterlace-mode=blend

but to no avail


Use the pipe ‘|’ symbol to add different options.

Whenever you find explanations on the VLC forums they will use either ‘–’ (this is how you add options if you start vlc from the command-line) or they will use ‘:’ (when used from within the program).

I have chosen to separate options with ‘|’, so in order to enable deinterlacing you should use:

dvb-t://frequency=490000000:bandwidth=8 | deinterlace=1 | deinterlace-mode=blend

So all command-line options found here, shouldn’t be sparated by --, but by |.

Also, you didn’t follow my example closely enough, as I use ‘=’ to select the program, and I used programs instead of program (allthough I don’t know if that matters here)


As someone with a device to control luminance and chrominance color brightness by vvvv etc in time to go crazy … SDI / Analogue TBC Synchronizer


Hi @ft
no way, I can t change the programs. The behaviour is as described before. In the example I ended up with the wrong “:” instead of “=” because I was trying all kind of possibilities (same as with program and programs) but the behavior is as described with the correct values.
Can you change the program with your interface?

I can select channels here when I use ‘program=xxxx’

(program numbers found in VLC->Extra->Codec information Ctrl-J)

EjE! I ve just found out myself right now! Yes it seems like programs is calling all the programs but then you need some extra option from menu to get the right one, while program loads just the one you chose in the string.

Not to derail the topic or anything, but do you guys have the VLC plugin working on 45beta27? I can’t seem to get it to not be red. 8(

the same parameter which worked with the plugin do not work anymore with the VLC node, could that be fixed?