Forum

Suddenly can't create Renderer (EX9) nodes

I can no longer create Renderer (EX9) nodes. Needless to say, this is a problem.

Last night, it was working correctly for a while, and at some point I saved a patch and got a few error messages in the logging output in a Renderer (TTY) : “Corrupt link-message in…”, “couldn’t connect pins of unknown nodes. deleting action”, etc. I’ve seen these error messages somewhat regularly, but in the past they haven’t really seemed to cause any noticeable problems. So… the patch saved.
Today, when I opened the same patch, I got an exception dialog, and the renderer node didn’t show up. I also got the same result when trying to add one to an new empty patch.
I haven’t changed vvvv versions or updated or anything between when it worked and when it stopped working. Afterwards, I did an update from Git (which pulled the new binaries), and still encountered the same issue.

I’ve attached a copy of the info from the exception dialog.

Any ideas on how to fix this?

vvvv-renderer-error.txt (26.4 kB)

one possible cause: last night was the first time in a while that i used a second monitor and move the renderer onto it.

odd,
after enabling the second monitor, did you restart? i had moments where this was necessary.

also try again with one monitor just to rule that out.

I had been encountering the error while using 1 monitor.

I appear to have solved the issue.
steps:

  • reattached the second monitor
  • opened vvvv
  • created empty patch on 2nd monitor
  • created renderer in that patch (and it worked)
  • dragged the renderer over to the 1st monitor
  • closed the patch
  • created another empty patch on the 1st monitor
  • successfully created a renderer in that patch
  • closed vvvv
  • detached 2nd monitor
  • opened vvvv
  • … and now i can create renderers again.

so… not really sure what was going on there but it’s working now.