Hi… sorry for the possibly dumb question.

I didn´t really find the answer to this in the forum, so… :

XFile Geometry Loader says the attached x file has 4 Subsets but i can´t get
them differently colored or transformed.

Trying out the feature with the vvvv- helps “SubsetCube” does work like i wish.

Can anyone pleeeease tell me why?

Mesh has been exported from c4d btw… i tried out different
exporters (there´s an old plugin, i used to use… i remember getting
subsets exported right then) and c4d- versions, but nothing works.

Cheers, C (1.6 kB)

yep. seems a problem with your file/export. it only has one visible subset. the others are empty.

xFile is a beast, you may try Collada, it s been more friendly in Blender and i see there is C4D native support too.

My personal beast tends to be Collada, so i´d prefer to use xFiles :-)

The mad thing is I used to get perfect xFiles out of cinema4d some time ago, but now i don´t… i remember having to try and error a lot ´til i found out how it works best.

But now… after two years of loosing brainpower… everything is gone again.

Might it be there has to be some specific texture- assignment? I only put a texture on the colorchannel in c4d…

Which 3D- Application would be the best choice to get this thingy built and exported, then?


x file export from c4d never worked for me, dont know why.
try collada export from c4d project file with all textures(!), which save before, not “on the fly”!
after use mesh collada node to open in vvvv and writer x file node to create a new x file.