Stride displays colors wrong

The same color applied to the background of a SceneWindow and a Renderer is slightly off. Skia displays it correctly, but in Stride it is slightly darker.

This should be due to default PostFX being applied in a SceneWindow. If you disable “Enable Default Post Effects” on the SceneWindow, colors should show as you expect.

Ah okay thanks! Maybe the default PostFX should then be set to values that let the colors appear like you would expect them? Also then a common look across Stride and Skia can be achieved, without knowing about that exception.

1 Like

The tone map needs to be there because the render pipeline is HDR. That means color values can be above 1. The tone map will map the colors back into to 0…1 range so that the monitor can display them. Skia is LDR, so unfortunately it’s different and it’s something you have to know.

If you turn it off, the lighting calculations will be incorrect. And since it’s a 3d window with lighting enabled, the default is on, so that not everybody writes, oh why aren’t my lights add up properly, this should be on by default. :⁠-⁠)

3 Likes