Forum

Strange experience with cleye

was using b33.7 with latest (official) imagepack and cleye driver for weeks on a win7-64 machine, when today, at the first bootup, the listdevices (cleye) started returning nill and vvvv will crash for every videoin(cleye) activation since then

  • test tool is working outside of vvvv
  • tried reinstalling vvvv and driver /same
  • tried another cam /same

any idea about what could have happened ?

looks like related to this discussion https://github.com/elliotwoods/VVVV.Packs.Image/issues/59

to be more clear,
i was after 1x videoin(cleye), qvga resolution, contour(opencv)
i had it working under w7-64, b33.7 with latest image pack for a month,
until the 14th april when (without adding new software) it all stopped working.

setup1

  • cleye driver 5.3.0.0341
  • beta 33.7
  • imagepack for b33

crashing every time i activate videoin(cleye)

setup2

  • cleye driver 5.3.0.0341
  • beta 27.2 (used to work for me)
  • imagepack from may2012

videoin(cleye) works at qvga resolution but contour(opencv) is unusable/red
…could the contour interfere with some more recent dependencies that make it run differently then when b27.2 was the latest version ?

sidenotes

  • old(free) and new(payed) cleye driver (5.3.0.0341) seem identical
  • tried different cameras so its not the hardware
  • tried de&re-installing all mentioned software
  • if i install the (multicam) cleye platform sdk 1.6.4.0028, videoin(cleye) will work but the qvga image is scrambled as in a bad mapping between data and pixels

questions

  • any other configuration i could try out ?
  • could the cleye driver deactivate date-dependent ?
  • any chance that this most powerfull pack could come in a more solid/payed form, that us, enthusiastic-non-compilers, hoarded here by vvvv itself, could use ?

can anyone run videoin(cleye) at 320x240 at the moment?
if yes please drop a message with which beta/pack/driver… thanks

we did this project in 2013 with cleye

configuration was b27.2, cleye driver 5.3.0.0341, imagepack from may2012

to my testing, it is the only pack that supports qvga (320x240), hence 175fps

problem is, even on a fresh windows install,
if i run b272 now, the contour(opencv) is red (attached demo patch)
if i run any other pack version, qvga wont work.

so now we are left with no combination of software to redeploy that project
anyone has an idea about how to go on with this ?

contour(opencv) problem in 27.2.v4p (1.0 kB)

in b33, if i also install the (multicam) sdk, i get an output in qvga format, but it is scrambled like this:

any idea if this could be unscrambled without … recompiling ?

ui, i think i found a solution for unscrambling qvga signal in b33

  • just put a resize node after the videoin(cleye)

also, if someone is planning to use canny on a cleye chain, it doesnt work unless you

  • first connect its input to a videoin(opencv) and then reconnect it to videoin(cleye)