Forum

Strange behaviour with vvvv, directx or what?

hi all
i’ve a big problem with vvvvv, vvvery strange problem
i’m using the wave shader from gregsn tiki-download_file.php?fileId=1200
after i don’t know what, render tty throwed this error: error in layer groupe, error in acces violation at address…
0040480A in module vvvv.exe
.read of adress 00000017
so, i tried all the possible things
rebooting
reverting my patch
power off/power on
so
i reverted redownloaded the original patch from gregsn
same error
uninstalled vvvv and reinstalled, deleted chache and other files in users folder
i don’t know
probably i can try to uninstall directx too
or the graphic card driver, and now i will try
but, anyone had similar behaviour before?

the problem was a vvvvvucking createEnum. a hint: don’t use it. for any reason. that may cause your death :)

ok, now im surprised :P

i stated this numerous times.
thx for confirming this.

sorry but this is occurs also with Ord2Enum. The enum system has a leak

I always avoid enums where possible, for historical buggyness, its still there it seems!

tried to use with dll enumerations, as karistouf worte, also ord2Enum is a mess

ord2enum works for me when i avoid IOBox (Enumerations) in between.
especially when IOBox (Enumerations) Style is set to “list”…
except when dealing with the technique of a shader…
:D

Avoid all CreateEnum (Enumerations) and related nodes!

easy pals, don’t scare the users, better try again in the next release ;)

i avoid Enums where possible :(

aaaa thay geting out of screen! thay coming! RUN! thay nearly got me over!
no enums eating me!!! stop aaaaawwawawawwawaaw…

sorry tonfilm but also in the actual release the bug of enum remains…

For my part I arrive to recreate a mess of Enumeration for shaders technique every time I m Ctrl-D a S node with a name: vvvv doesn t support the doubleness of the same global variable in memory. It seems that enum has to do something with it, also…

question:
do you think that 24 and 25 are suitable for work ? For my part the answer is helas no, so i m staying on 23
Too much bugs in a couple of days to take the risk. The dynamic plug in is a hudge beautifull implementation but actually vvvv is too much ressources consummering and not stable at all. so it s better to send new users on a 23 actually. really

is it the same thing what is the thread about, or something different?
some strange sporadic shaders behaviour with beta23 W7_64 Quadro 3700:

  • no function,
  • loosing correct enumeration technic - showing instead nil or XY, WZ or enumeration belongs to another shader
  • cant save & overwrite the v4 file, instead getting new one with suffux ~temp1.v4p
  • TTY: error in layer …
  • dubugging: after shader next renderer > red
  • by closing: Application Error Exception EInvalidPointer in module vvvv.exe at 000047C9
    but i have no CreateEnum (Enumerations) in the patch?

there seems to be some bogus in your patch.
have a close look to the .v4p using an editor or better the free XMLmarker.
or attach last ~temp version here.

thanks kalle. by making the patch portable, or changing directory everything starting be all right.