Startup issue with native instruments kontrol f1

hello belovvvved devvvvs,

i just received this very nice controller and it really pities me that my favourite tool won’t start with the controller attached to the system. (works again the second i remove it. also instantly crashes vvvv when beeing connected while it’s running) tested on beta27.2 and alpha28.

log attached ;)

startup log (2.2 kB)

hm…odd, but most likely a HID problem… like with the ms-surface…
mm hard to debug without the device though…anyone in berlin with such a device?

i know some people at NI support, so i could ask them if that would help…

if you start with an alpha-build…do you get a more detailed exception?

sorry for the late answer. i forgot to subscribe to this thread :|

the log was already from alpha 28. just tried a newer alpha (vvvv_45alpha28-develop-697babe35ef333807c1b342acb381035b432116a). no dice. log is also identical.

for further reference i also attached a beta 27.2 log.

alpha 28 log with f1 controller (2.2 kB)
beta 27.2 log with f1 controller (299 Bytes)

please now try again with latest alpha. (should now stop at HID init…just to confirm my theory)


log from latest alpha28 (2.2 kB)

mkay…which brings us back to fact that i’ll need such a thing here to debug this further…

finally heard back from my friend at NI. help is hopefully on it’s way…

hei m4d, device arrived. can you please try that again with latest alpha?

works now :)

big up devvvvs and NI!