Forum

Startup in multiple fullscreens

hello. i have 2 videocards (3 projectors, 1 preview).
when i run my patch, i need the 3 projectors to go directly fullscreen. what happens instead is the fullscreens go gray. if vvvv is allready running when in run the patch, they go hidden.
how do i do this? args maybe?

hola ggml,

which cards are you using? latest drivers?
which mode have you set on the cards: dualview or spanmode?
how many renderers are you using?
how are you setting them fullscreen? using the fullscreen-pin or just alt-enter and saving them fullscreen?

more details please…

yes
my setup is like this:
2 x nvidia 8600 gt with latest drivers, dualview = 4 screens

my patch is like this:
3 projectors with renderers in fullscreen (fullscreen pin = 1), 1 tft for patching

and this is what happens:
everything works fine if i first run vvvv, then load the patch.
BUT
all renderes are grey if i run the patch directly (and this is what i need)

thanks

  • all renderes are grey if i run the patch directly (and this is what i need)
    you mean with something like
    /o mypatch.v4p
    specified in args.txt?

anyway you could try adding some delay to the fullscreen-pin. so that the renderers actually start windowed but only after one second switch to fullscreen.

ok, the delay on fullscreen pin is working, thanks joreg.

also, for this to work its important NOT to alt+enter the renderers before saving the patch, just place them on the right screens.

edit: this leads me to another problem:

if this installation of mine loads on the setup it has been saved on, everything is fine.
BUT
i imagine a situation in wich one or two of the 3 projectors will be turned off. in this case, the render windows are scrambled. can i assign render windows to specific screens ? (identified as in windows display settings maybe)

or i could fake the presence of projectors at all times by something like the dummy connector/paperclip hack (link), but then i would have to use switches for all 3 projectors, so that the videosignal gets to the projector if it is on (and if not, letting the dummy connector fake it) ?

let me restate:

the problem in solving different dualview setups (1=preview, 2,3,4=projectors vs. 1=preview, 2,3=projecotrs vs. 1=preview, 2=projector) with the same patch going fullscreen lies in the fact that windows display settings is changing the arrangement of the screens.
example:

  • in windows display settings, i allign the screens horizontally:

1_2_3_4

i make a patch that goes fullscreen on screens 2,3,4

  • plugging off screen number 3, restart system, instead of the expected 1_2_3, i get this screen arrangement:

1_3
__2

the patch goes fullscreen only on number 3
i get similar scramblings with different combinations of displays turned on/off

what i would need to do in a software sollution is to be able to tell the patch to go fullscreen on all displays but the primary display, in a given order (even in a non-given order)

i havent been using the (VVVV) nodes category but if i could get the “desktop-space” information (how the screens extend left/rigt/up/down of the primary display) maybe i would be able to use SetPatch(VVVV) to state how many render windows are needed and where to move them before going fullscreen.

i hope i am not spamming the vvvvorums with this brainstorm talk, maybe someone has solved this problem much simpler ?

i think i remember there was a professional hardware solution for this. a connector that always assures that windows detects the screen. don’t remember its name now though…

alternatively you could try with Device (EX9 Manual) . see the link for details and please report back if that works for you.

i think i remember there was a professional hardware solution
for this. a connector that always assures that windows detects
the screen. don’t remember its name now though…

it is called DVI Detective

i think i remember there was a professional hardware solution
for this. a connector that always assures that windows detects
the screen. don’t remember its name now though…

or even nicer as you can preset resolution manually HDCP-Manager

alternatively you could try with Device (EX9 Manual) .
see the link for details and please report back if that works for you.

Device (EX9 Manual) seems to work for me.
Spreading pins Adapter, Deivce Type, VertexProcessingMode and assigning the renderers to each adapter seems to do the job.
The displays go fullscreen like this:

active display
device assigned

1 2 3 4
1 2 3 4

1 2 4
1 2 3

1 4
1 2

instead of:

1 2 4
1 2 4

1 4
1 4

maybe i will get into this at a later point, now i have to check other aspects of the installation

thanks again