Forum

Some plugins quit working in beta18

as an example - particles (and some of my own) plugins don’t work anymore. maybe that has something to do with xxx.PinIsChanged ???

a way to fix that (from irc chat with joreg):

09:29 m9dfukc: hey joreg, maybe you already read my bug report on vvvv.org
09:30 m9dfukc: … maybe it’s also just too early in the morging and I do something totally wrong
09:33 iorec: ai.
09:34 iorec: try updating utils and pluginterface.
09:34 iorec: compile one of your plugs with them and put the new _utils.dll and _pluginterfacce.dll in the \plugins dir
09:34 iorec: see if the plugs work then

… for all the people which can’t wait for the fix ;)

But how one would do this? I have a patch the relies on the plugin Particles (Spreads Multiple), and it stopped working. :P

… sorry for my vvvvignorance. :)

@candian:

you can copy the two files in the attached zip (working versions of plugininterface and utils) in the plugins folder.

That should make it work.

plugins.zip (18.0 kB)

hmm…i am a bit off these days…sory for the mess. but does this fix actually work? please report your findings.

at least for me that fix worked!

Had a look for the plugin, and here is a temporary solution:

Get the files _PluginInterfaces and _Utils.dll from beta17 version (in the plugin folder).

Copy those two files in the beta18 plugins folder.

Should make it work again.

It seems that neither solution has worked for me. I tried to use the zip file provided and the DLLs of beta17, only to find the same problem.

It seems that it only works in beta17. But in this version, my camera does not work, bug fixed in beta18. But I need that particle generator!

Any clues so you guys can help me out? Please? :D

Ok, a new issue. :)

I had beta18 installed on my laptop (Vista), and, as expected, Particles (Spreads Multiple) didn’t work.

Then, I downloaded vux’s zip file and extracted the files to the plugins folder. Nothing.

Then I downloaded beta17 and extracted the two files to the plugins folder. And… suprise! It worked.

So, now the new problem is: why it worked on my laptop with Windows Vista and it didn’t on my desktop with XP? Maybe it has something to do with the fact that I have the three versions of vvvv installed on it (16, 17 and 18)? On my laptop I have only beta18.

Guess this is one more episode for the V-Files… :D